Home Dashboard Directory Help
Search

Text sometimes not visible while editing text boxes in Internet Explorer 10 by PublicProfile22490


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


Type: Bug
ID: 785910
Opened: 4/30/2013 6:23:41 AM
Access Restriction: Public
0
Workaround(s)
view
1
User(s) can reproduce this bug

Description



I recently updated to Internet Explorer 10. Sometimes when I am editing the text within a text box, the text is hidden. It is not deleted; it is just hidden. This most often happens when using the backspace key. I'll click into the text box, use the mouse the put my cursor at the end of the existing text, press backspace, and then the text is invisible. The text is still 'there', as I need to continue backspacing to delete additional characters, but this makes it difficult to see how much I need to backspace. I have also seen this behavior when typing new text into a text box.

Examples of where this has occurred:
SQL Server Reporting Services; I am often using the text box for the report name when creating a linked report. This always happens in this situation.
SharePoint; I am entering data into standard list item forms. This always happens in this situation.
Registering for Microsoft Connect; when I was editing my company name, I also saw the text disappear. I do not plan on trying this several times.

Also, I should mention that I am using the 150% DPI setting. I am using Windows 7 Professional, 64 bit.
Details
Sign in to post a comment.
Posted by sgregpa on 11/13/2013 at 3:50 PM
More info... this appears to ONLY happen when accessing the webpage using an Intranet URL.
Example:
- http://<server>/path/filename.aspx - Reproduces the problem
- http://www.company.com/path/filename.aspx - does NOT reproduce the problem

I have reproduced this problem when testing against multiple servers that we have set up.
Why this is happening is a mystery to me, but hopefully all this detail is seen by someone and helps to track this down.
Thanks!!
Posted by sgregpa on 11/13/2013 at 3:34 PM
I appear to be unable to add attachments, so here is the code for the simplified page which reproduced this problem for us.
Hope it comes through.

<html>
<body>
<p>Reproduce disappearing text box problem</p>
<form id="myform" runat="server">
<asp:Label ID="myLabel" runat="server" Text="Name"></asp:Label>
<asp:TextBox ID="myTextBox" runat="server"></asp:TextBox>
</form>
</body>
</html>
Posted by sgregpa on 11/13/2013 at 3:33 PM
When hosting the attached ASPX webpage on our Windows Server 2008 R2 Enterprise server using IIS I can reproduce a problem which I believe is the same as described here, although it does not involve SSRS.

Web Server:
Windows Server 6.1 (Build 7601: SP 1)
IIS v7.5.7600.16385

Client:
Windows 7
IE 10 (10.0.9200.16635 w/update versions: 10.0.7)

STEPS:
1) Host the attached page BugRepro.aspx (renamed from the attached name of .txt) on your server.
2) Navigate to the web page using IE.
3) Use your mouse to click in the single text box on the page.
4) Type "test" and then hit Backspace.

RESULT:
The text box border and the text within the textbox disappears.
If you start typing again the textbox and the undeleted contents will reappear.

If the problem stops happening refresh the page and try again. Somehow the probably appears to stop occurring after the page has been open awhile and text edited repeatedly and the mouse moved around... not sure why. But after refreshing it consistently reoccurs.

I am unable to reproduce this problem when viewing the page using Chrome.
I am unable to reproduce this when hosting the page locally in Visual Studio 2010 on my dev system.

This problem only seems to appear when an ASP:Label control appears immediate before (ignoring whitespace and nbsp's) before the ASP:Textbox control.
Assuming you can reproduce this problem you will see that if you put an "x" character after the label, before the textbox, the problem will no longer reproduce.

If you can not reproduce this please contact me and perhaps we can have you try this viewing this aspx file from one of our internal servers.

Thanks for the help!
Posted by jbruns7 on 8/22/2013 at 6:26 PM
I recently updated from IE 9 to IE 10 and am experiencing the same issue. In certain text fields, if I type something incorrectly and hit the backspace key, all of the information in that field becomes "hidden" (for lack of a better word), but the information is still there; as soon as you start typing again it shows back up. It is very difficult to correct data when you can't see it. Has anyone found a solution? I am able to take SnagIt screenshots and can forward them if needed so you can see what I am referring to.
Posted by Microsoft on 5/2/2013 at 8:48 AM
Thank you for your feedback.

We are currently unable to reproduce this issue as described.


We value your feedback. If you have additional information that can help us recreate this issue — such as a specific url, more detailed steps, test results from different machines, or additional conditions — please reactivate the bug or submit a new bug with more details on how to reproduce the issue. You can also read the guidelines at https://connect.microsoft.com/IE/content/content.aspx?ContentID=16254 regarding filing a good bug report.

Best regards,

The Internet Explorer Team
Sign in to post a workaround.