Home Dashboard Directory Help
Search

Strange behaviour after latest security update by Kalle_L


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


Type: Bug
ID: 789424
Opened: 6/4/2013 1:46:37 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

After the latest security update for IE 9 I have noticed some strange behaviour on all of my computers running IE 9.

When for example embedding a Youtube video in an iframe and then removing the iframe using javascript, nothing happens. The html code is updated but the updated html code is not rendered by IE 9. Sometimes IE 9 hangs completely.

Running IE 9 in compatibility mode everything works perfectly okay.
Sometimes it is also possible to remove the iframe by trying multiple times.


The code below was working perfectly okay before the security update!

Example code:

<!DOCTYPE html>
<html>
<head>
</head>
<body>

<script>
function run()
{
var iframe = document.getElementsByTagName('iframe');

count = 0;
while(count < iframe.length)
{
iframe[count].outerHTML = '';
count++;
}
}

function html()
{
alert(document.documentElement.innerHTML);
}
</script>

<input type="button" value="Remove" onClick="run();" />
<input type="button" value="HTML" onClick="html();" />
<br>
<br>
<iframe src="http://www.youtube.com/embed/QH2-TGUlwu4" width="480" height="360" style="border: none"></iframe>
</body>
</html>
Details
Sign in to post a comment.
Posted by Microsoft on 7/1/2013 at 7:42 AM
Thank you for your feedback.

We are currently unable to reproduce this issue as described.

We value your feedback. If you have the additional information requested, please let us know you still have a repro after the updates.
Please also note we have released a new preview version of Internet Explorer which is included with Windows 8.1 available from the following location: http://windows.microsoft.com/en-us/windows-8/preview -
Please retest the issue on the latest relase of IE11 and If the issue continues please reopen this connect feedback item and provide additional details that will help us continue our investigation.
We welcome your feedback, please send us additional comments so that we can investigate further.

Best regards,

The Internet Explorer Team
Posted by AxelRMSFT on 6/5/2013 at 2:53 PM
Could you outlined which update are you talking about?
MS13-037(http://technet.microsoft.com/en-us/security/bulletin/ms13-037) or MS13-038 (http://technet.microsoft.com/en-us/security/bulletin/ms13-038) ?
Did your client machine had a previous IE cumulative update installed (MS13-028 - https://technet.microsoft.com/en-us/security/bulletin/ms13-028)?

If the page is loading Adobe Flash, can you also make sure your client have the latest version of Flash?

For the iframe, does it have to be an embeded video or do you see it crashing if you have a simple page or an image in it to see your issue?

Thanks!
Posted by Kalle_L on 6/4/2013 at 6:05 AM
I can now also confirm that this bug exists in IE 10 on Windows 7.
Posted by Kalle_L on 6/4/2013 at 4:18 AM
This bug has been confirmed by other users to.

As I wrote in the bug descrition, it is possible to remove the iframe by clicking the "Remove" button multiple times, and sometimes the iframe is removed and sometimes is it not removed.

I also noticed that if you click on the iframe, after you tried to remove the iframe, IE hangs.

If you scroll the window after you tried to removed the iframe, the iframe is not scrolled together with all the other content on the web page, i.e. the iframe is frozen in place.
Posted by Kalle_L on 6/4/2013 at 4:16 AM
You can read more about this bug here: http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/thread/eb897e12-3942-44e6-adb5-4a67c993d4c9
Sign in to post a workaround.