Home Dashboard Directory Help
Search

Css3 transition with transform3d need starting value by minimit


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


Type: Bug
ID: 790405
Opened: 6/18/2013 1:12:19 PM
Access Restriction: Public
1
Workaround(s)
view
0
User(s) can reproduce this bug

Description

Seems IE10 has a bug with Css3 transition with transform3d. In some circumstances IE10 doens't do the transition right, because he don't have the "starting values", if you set them before the transition it fixes the bug, but this should be fixed.

As you can see here http://jsfiddle.net/minimit/ps4qL/ without the IE10 fix commented lines IE10 bugs the animations and doesn't do the right rotation transition, in other circumstances the fix isn't needed as you can see here http://jsfiddle.net/minimit/FnRNa/ or here http://jsfiddle.net/minimit/Hk8SX/
Details
Sign in to post a comment.
Posted by Microsoft on 6/28/2013 at 1:05 PM
Thank you for your feedback.

We are currently unable to reproduce this issue as described.

It's not clear to us what isn't correct. A quick look in IE10 and Chrome look the same. Please be more specific than "rotate the right way" and we will revisit this reported issue.

We value your feedback. If you have additional information that can help us recreate this issue — such as a specific url, more detailed steps, test results from different machines, or additional conditions — please reactivate the bug or submit a new bug with more details on how to reproduce the issue. You can also read the guidelines at https://connect.microsoft.com/IE/content/content.aspx?ContentID=16254 regarding filing a good bug report.

Best regards,

The Internet Explorer Team
Posted by Microsoft on 6/20/2013 at 12:54 PM
Thank you for your feedback. We will be investigating this issue further.

Best regards,

The Internet Explorer Team
Sign in to post a workaround.
Posted by minimit on 6/18/2013 at 1:13 PM
Setting the animation to the start position before animating.