Home Dashboard Directory Help
Search

Net Share prompts are not visible in the ISE by thisuniquename


Status: 

Active


2
0
Sign in
to vote
Type: Bug
ID: 787174
Opened: 5/17/2013 12:06:19 PM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

If you run Net Share {ShareName} /Delete in the ISE and there are files in use, you do not see the prompt to continue the operation. The console in the ISE only shows the first half of the message which reads "Users have open files on {ShareName}. Continuing the operation will force the files closed." The second half of the message, "Do you want to continue this operation? (Y/N) [N]:" does not appear in the ISE console.

If you try to stop the script, the ISE continuously attempts to stop the script. Using Process Explorer, I found that Net1.exe continues to run but not as a child of the ISE. Killing Net1.exe allows the ISE to stop the script.

This command runs without issue in the stand alone console. This issue also happens in PoswerGUI. I'm assuming the ISE should display a popup with the prompt from Net1.exe but it fails to handle that.

Further testing shows that after closing the ISE when you encounter this issue leaves Net1.exe running in the background. I had several instances of Net1.exe running before I closed them using Process Explorer.
Details
Sign in to post a comment.
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
net share issue.png 5/17/2013 14 KB