Home Dashboard Directory Help
Search

SQL Server 2008 SP1 failed by Ana Mihalj


Status: 

Active


5
0
Sign in
to vote
Type: Bug
ID: 431591
Opened: 4/9/2009 5:30:28 AM
Access Restriction: Public
2
Workaround(s)
view
14
User(s) can reproduce this bug

Description

SQL Server 2008 SP1 install failed on my development workstation.
This workstation is Windows XP SP3 with SQL Server 2008 developer edition.

The patch installer has failed to update the shared features, but versions from SSMS -> Help -> About... and from @@version looks OK.
After failed install version is:
Microsoft SQL Server Management Studio    10.0.2531.0
Microsoft Analysis Services Client Tools    10.0.1600.22
Microsoft Data Access Components (MDAC)    3.85.1132
Microsoft MSXML                2.6 3.0 4.0 5.0 6.0
Microsoft Internet Explorer            7.0.5730.11
Microsoft .NET Framework            2.0.50727.3053
Operating System                5.1.2600


select @@VERSION
Microsoft SQL Server 2008 (SP1) - 10.0.2531.0 (Intel X86)
    Mar 29 2009 10:27:29
    Copyright (c) 1988-2008 Microsoft Corporation
    Developer Edition on Windows NT 5.1 <X86> (Build 2600: Service Pack 3)






Details
Sign in to post a comment.
Posted by Gurpreet S Sohal on 4/26/2013 at 7:24 AM
Hi All,

             i tried the same on a active passive cluster setup .. but it did not work for me ..

             i was upgrading to SP2 of SQL 2008 R2 ... any help will be great ..

             one of the nodes upgraded fine ,but the other node is giving the same error after copying and renaming the

             mentioned file


MSI (s) (78:08) [06:01:59:569]: Product: SQL Server 2008 R2 SP2 BI Development Studio - Update 'Service Pack 2 for SQL Server Business Intelligence Development Studio 2008 (64-bit) (KB2630458)' could not be installed. Error code 1603.
Posted by Andy Carter on 9/19/2012 at 3:13 PM
I can't believe this is still an issue 3 years later! This workarond has just solved my problem with installing Service Pack 2 for SQL 2008 R2. Thanks very much for posting.
Posted by jaackov on 6/29/2010 at 12:03 AM
the Overal summary section of the file Summary.txt is as follows:
Overall summary:
Final result:                 The patch installer has failed to update the following instance:. To determine the reason for failure, review the log files.
Exit code (Decimal):         -2067919922
Exit facility code:            1214
Exit error code:             3022
Exit message:                 The machine is clustered, but the cluster is not online or cannot be accessed from one of its nodes. To continue determine why the cluster is not online and rerun setup instead of rerunning the rule since the rule can no longer detect a cluster environment correctly.
Start time:                    2010-06-29 10:55:58
End time:                     2010-06-29 10:57:55
Requested action:             Patch

i tried to cancel the cluster and omit the node out of the cluster. i created the cluster once b4 and i didn't continue it. it was just for some test. if the problem is for the cluster and that this is a node of a cluster which doesn't exist anymore, i prefer it to be cancelled. how can i do that?
Posted by jaackov on 6/28/2010 at 11:45 PM
hi
i've the same problem. copying the file devenv.exe.config to devenv.exe.config.tmp (not renaming it, keeping the original) also didn't help.
i'm going to attach log, but there're two problems. first, i don't know which file to attach between lots of folders and files located in c:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log. assuming Summary.txt is mentioned, i still don't know how can i attach a file to my post.
Posted by Microsoft on 5/28/2010 at 9:55 AM
Hello -- We investigated this issue and provided a fix that will ship in SQL Server 2008 SP2. This item has been resolved as fixed and closed.

Thank you for your assistance,
The Analysis Services team
Posted by Wayne_K on 8/24/2009 at 7:30 AM
I'm running Vista Home Premuim with SQL Server 2008 Developer Edition. My SP1 upgrade failed with the same error messages defined in this bug. As per the recommended workarounds, I do not have NTFS compression enabled, so this is ruled out. Can anyone attest to the success with the devenv.exe.config solution? Thx.
Posted by Ana Mihalj on 5/11/2009 at 1:23 AM
It’s working.
I created file as you specified, and then stopped all sql server services.
Run setup.
1. On welcome window all rules are passed
2. I accepted licensed term
3. On Select Features window MSSQLSERVER and Shared Features are checked by setup
4. On Check Files In Use window there is no files
5. Setup completed successfully.
Posted by Microsoft on 5/8/2009 at 3:56 PM
A potential workaround for this issue is to copy your existing c:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\devenv.exe.config file to another copy called devenv.exe.config.tmp and then re-run setup. Can you please try this and let us know what the result is?

In addition, can you provide a more detailed repro by providing the exact steps that you are following? From the reported issue, it is difficult to determine what steps are being followed and in what order.

Thank you for your assistance.
Posted by Microsoft on 5/6/2009 at 9:53 AM
This issue was assigned to the Analysis Services team on 5/5 for investigation. This issue has been assigned to a developer and as soon as we have additional information, we will post more information.

Thanks ~
Posted by Cristin on 5/6/2009 at 8:25 AM
What is the resolution to this? I'm fighting with the same issue - an upgraded Integration Services and Reporting Services fails to update sith SP1. The installation window states incomplete Installation when I select the details of that feature. I have run a repair to the SQL Server 2008 installation, and still had the same error when applying service pack 1. Please post a resolution. Thanks!
Posted by Microsoft on 5/6/2009 at 6:31 AM
Thanks Amihalj,

We'll investigate this now. Thanks again for reporting.

The Analysis Services Team
Posted by davidtg on 5/3/2009 at 10:14 AM
We're experiencing the identical problem on Windows Server 2008 with SQL 2008 Developer Ed. SSMS reports version of 10.1.2531.0 for the database engine and Analysis Services but for Integration Services its still 10.1.1600
Posted by Shril Pyrrho on 5/1/2009 at 7:22 AM
I'm having the same problem but on Vista x64 SP1

Posted by rtemplin on 4/25/2009 at 11:26 AM
I am experiencing the same error, and am also running 2008 Developer Edition on XP SP3.
Posted by Ana Mihalj on 4/14/2009 at 1:39 AM
I attached CAB file from the log folder.
Posted by Microsoft on 4/10/2009 at 8:59 AM
Thanks for reporting this issue. In order to diagnose the cause, we need the setup logs. Please attach them to this issue. They are located under:

%programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log

Thanks,

Max Verun
SQL Server
Sign in to post a workaround.
Posted by Scott Gill on 6/16/2009 at 11:36 AM
Removing NTFS compression from all SQL Server 2008 installation directories (if it is present) also resolves this problem.
Posted by VYSEA on 5/10/2009 at 1:04 AM
Copy one devenv.exe.config from C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE to C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies .
and rename it to devenv.exe.config.tmp .
Then SQL Server Business Intelligence Development Studio Patch will success.

It's caused by a little bug with the SQL Server Business Intelligence Development Studio shared component integrating into VISUAL STUDIO 200X .

I procmon it sql_bids.msp of one patch inside the SP1 package. The result is cannot find the specified files.
On my system, the devenv.exe.config.tmp is missing ( i don't understand why the patch need a tmp file)
Maybe you can procmon it on your own computer.

P.S. first kill every msiexec.exe process, because it may possess some file the patch is needed.
File Name Submitted By Submitted On File Size  
Summary_hawai_20090409_121543.txt (restricted) 4/9/2009 -
SqlSqmShared_Cpu32_1.log (restricted) 4/9/2009 -
LogSet_hawai_20090409_121543.cab (restricted) 4/14/2009 -