Home Dashboard Directory Help
Search

SSRS groups inside groups don't show aggregations by Ivan.Z. _


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


11
0
Sign in
to vote
Type: Bug
ID: 519660
Opened: 12/10/2009 1:46:49 PM
Access Restriction: Public
0
Workaround(s)
view
10
User(s) can reproduce this bug

Description

I am trying to add two adjacent groups inside another row group in matrix.

However, I can't get aggregations to show for both groups. Numbers are shown only for the second group.

How to reproduce this:
1. Put matrix on report
2. Fill rows, columns and data
3. click on row group, add parent group
4. click on inside row group, add group adjacent before
5. add aggregations for new groups

I am using SSRS 2008.

Could anyone explain this? Is this bug or feature? I can get this to work if there is no parent group.

Thanx!
Details
Sign in to post a comment.
Posted by Bluey47 on 3/12/2013 at 8:41 PM
This is still a bug, happening to me right now. Interestingly the values are correct in VS2008 preview but when I deploy its exactly like everyone else here has said.
Posted by rvonclausburg on 1/26/2011 at 7:09 AM
I would be happy to provide an RDL and sample data to reproduce this problem/bug. I would also be willing to allow a MS tech access to my PC while I demonstrate the problem. As a work around I created a master report that calls sub reports that represent the adjacent groups. I needed to create 4 reports passing multiple parameters to do the work that should be accomplished in 1 report.
Posted by Matt Reynolds 42 on 10/15/2010 at 10:23 AM
Likewise, I agree with DCrissman. This is an easily reproduced bug, and the trick to reproducing it is exactly as he described. This bug needs to be reopened and addressed.
Posted by DCrissman on 4/7/2010 at 6:27 AM
I've encountered this issue as well, but in my experience, there are additional conditions that contribute to it. As described above there need to be two or more adjacent row groups inside of the same parent group, but additionally, the calculation must also be inside of a column group.

I've created an RDL file that can be used to reproduce the problem, and I can provide it if necessary.
Posted by Microsoft on 1/11/2010 at 8:37 PM
Thanks for your feedback on this issue. Unfortunately, we are unable to reproduce the problem based on the information your provided. If you can provide an RDL that demonstrates the problem, or other information that might help us reproduce it, please do so and we will be happy to take another look.
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
Matrix problem 2.jpg (restricted) 12/10/2009 -
Matrix problem 1.jpg (restricted) 12/10/2009 -