Home Dashboard Directory Help
Search

SSRS 2012 SP1 RTM reports not rendered on iPad by jiri_hubacek


Status: 

Active


10
0
Sign in
to vote
Type: Bug
ID: 770662
Opened: 11/9/2012 3:56:41 PM
Access Restriction: Public
0
Workaround(s)
view
2
User(s) can reproduce this bug

Description

When reports deployed to SSRS 2012 SP1 in Native mode are accessed on the iPad or iPhone they do not render. Control buttons are visible everything looks fine but the report itself is blank. When export to PDF is chosen report is successfully exported to PDF and opened on iDevice. See screens.

OS hosted on vmware workstation 9.0.0
Details
Sign in to post a comment.
Posted by Alexander Kalenkov on 4/30/2014 at 6:57 AM
Ssrs 2012 with latest updates. Same issue. Safari unable render report on ipad ios 7.1.1.
Posted by lghost on 11/22/2013 at 12:30 PM
It seems that you must use reportserver and not reportmanager. I just did this and it now works. In case anyone was wondering, that was how it was on the ipad2, which is why that one worked.
Posted by lghost on 11/22/2013 at 12:08 PM
SQL Server 2012 11.021. Finding exactly what is posted only for ipad airs. Parameters work fine but report does not render. When export to PDF it shows up.    However, it works fine on ipad2s.
Posted by William Lowers on 11/7/2013 at 5:58 AM
I have this same issue on a fresh install in native mode. Version is 11.0.3128. Parameters all work fine but report is empty. This is also on the new iPad Air. SSRS and SQL Server are on the same server and at the same patch level.
Posted by JTW66 on 9/12/2013 at 6:21 PM
I have just discovered that if I setup a subscription to send email with link and connect to the report server by clicking the link the report data does display. Perhaps this is by design?
Posted by JTW66 on 9/12/2013 at 6:00 PM
I am also seeing this issue on SSRS 2012 version 11.0.3000. My server is 2008R2 SP1 hosted on VMware ESX 5.1.
Posted by Mr Tintin on 6/6/2013 at 7:36 AM
I got this on RTM (as expected); installed SP1 and have the same issue. If I find a resolution I'll note it here.
Posted by bt_avanade on 2/5/2013 at 11:49 AM
I've downloaded and deployed the latest version (11.0.3000.0) and it is working on my client's IPhones
Posted by Bill Ramos on 11/23/2012 at 8:59 AM
This doesn't appear to be fixed in 2012 SP1 CU1.
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
pdf.JPG (restricted) 11/9/2012 -
web.JPG (restricted) 11/9/2012 -
web.JPG 11/9/2012 137 KB
pdf.JPG 11/9/2012 337 KB