Home Dashboard Directory Help
Search

XMLA discover bug by Snap


Status: 

Active


6
0
Sign in
to vote
Type: Bug
ID: 778409
Opened: 2/3/2013 10:36:03 AM
Access Restriction: Public
1
Workaround(s)
view
2
User(s) can reproduce this bug

Description

Hi

We have a client's cube that when queried using XMLA discover we get this error in Mngt Studio (2012):

Executing the query ...
The --> text node at line 29, column 31 cannot appear inside the PropertyList element (namespace urn:schemas-microsoft-com:xml-analysis) under Envelope/Body/Discover/Properties. This element can only have text nodes containing white-space characters.
Execution complete

If we attempt to crank it through a programmatic XMLA discover call we notice that each node in the returned XML document has a 'column number' attached at the end "CATALOG_NAME" becomes "CATALOG_NAMEC00" etc. See attached image for more.

The cube is localized to German and is opened to a client that has German regional settings. What makes it strange is that we only see this reponse one one hierarchy in one dimension. All the others work as normal.

We've looked at all the settings and we cannot spot the reason for the problem and a switch to turn it off.

thanks in Advance
snap
Details
Sign in to post a comment.
Sign in to post a workaround.
Posted by Snap on 2/12/2013 at 2:53 PM
Seems that since no one even knows where this problem comes from, its up to us to fix it manually(!@#).

The current solution involves reading in the schema, swapping out the "sql:field" attribute against the element name and then getting a cleansed element name without the extra character appendages.

It would be nice if this was solved from the get-go in SSAS.
File Name Submitted By Submitted On File Size  
2-3-2013 1-25-00 PM.png 2/3/2013 41 KB