Home Dashboard Directory Help
Search

Report returns "Object reference not set to an instance of an object." error after upgrading to SQL 2008 R2 SP2 by manuvigno


Status: 

Closed
 as Fixed Help for as Fixed


1
0
Sign in
to vote
Type: Bug
ID: 783484
Opened: 4/11/2013 1:43:42 PM
Access Restriction: Public
1
Workaround(s)
view
0
User(s) can reproduce this bug

Description

My SSRS reports were running fine until I installed the service pack 2 for SQL Server 2008 R2.

Now when I try to run a report from the SSRS web page it returns:

An error occurred during rendering of the report. (rrRenderingError)
An error occurred during rendering of the report.
Object reference not set to an instance of an object.

I can provide a log file and mini dump file per request.
Details
Sign in to post a comment.
Posted by Microsoft on 10/16/2013 at 5:13 PM
“Hello,
Thank you for submitting this feedback.
The reported problem was already fixed. You can download the fix from:
1. http://support.microsoft.com/kb/2507770 - for SQL Server 2008 R2
2. http://support.microsoft.com/kb/2867319 - for SQL Server 2012
3. http://support.microsoft.com/kb/2861107 - for SQL Server 2012 SP1

Thank You again for reporting the product issue and continued support in improving our product.
Posted by manuvigno on 4/16/2013 at 12:13 PM
Note to reproduce this issue, you must have a background image in the page header for which the source is the database. If the image is embedded you will not see the error.

The reports with the bacground images from the database work correctly prior to installing the service pack 2 for SQL Server 2008 R2.
Posted by manuvigno on 4/11/2013 at 1:59 PM
Please note that after the upgrade to the service pack, I can still run the reports from Report Builder 3.0 without getting the error.
Sign in to post a workaround.
Posted by manuvigno on 4/16/2013 at 12:16 PM
I can get rid of the error by embedding the page header backgound image into my report template.