Home Dashboard Directory Help

saved shared data source credentials lost after restart by rschmitz


Status: 

Closed
 as Fixed Help for as Fixed


16
0
Sign in
to vote
Type: Bug
ID: 450753
Opened: 5/14/2009 4:31:05 PM
Access Restriction: Public
0
Workaround(s)
view
20
User(s) can reproduce this bug

Description

I recently installed Service Pack 3 for SQL Server 2005 on my local machine, and now my saved credentials for my shared data sources in my Reporting Services project in Visual Studio 2005 SP1 are gone every time I restart my computer. I have to enter the specific User Name and Password into the Credentials tab every day for each shared data source. This problem never occurred before I installed SQL Server 2005 SP3, and now my co-workers are afraid to install SP3 on their machines. The server already has SP3 installed.
Details
Sign in to post a comment.
Posted by Microsoft on 8/18/2010 at 11:39 AM
Thanks all for your feedback on this issue. A hotfix was requested by jacquesdereims. The fix was released in SQL 2005 SP3 CU8. The following page has information about the update and how to obtain it:

http://support.microsoft.com/kb/978915
Posted by Doylik on 4/20/2010 at 12:04 AM
Hi. Every time i get frustrated cause of this inserting user name and password i start looking for any solution on the internet and every time with no luck. I had similar problem with saving password in SQL server managemant studio 2005 and 2008 and that i fixed by deleting some files that someone suggested.
But with Visual Studio 2005 have no luck to find any solution.
Microsoft, PLEASE do something with this problem!
Thank you.
Posted by CamilleW1 on 4/14/2010 at 3:11 PM
Hi, I am using BIDS 2008 and this is still occuring - is Microsoft doing anything to fix this bug which did not occur when we were all using SQL Sever 2005 SP1 or 2?
It is very frustrating, especially when you have multiple projects with multiple shared data sources and have to remember to add in the credentials every day.

thanks.
Posted by Microsoft on 11/4/2009 at 3:38 PM
Plans for SQL Server 2005 SP4 are currently unknown at this time. If this is a time sensitive issue please contact a CSS representative via http:\\support.microsoft.com to request a personalized fix for this issue (aka, an RFC).
Posted by bbb1 on 11/4/2009 at 1:23 PM
Is anyone working on this at Microsoft? When can we expect a fix?
Posted by rschmitz on 9/27/2009 at 11:14 PM
I forgot to mention that several other people are asking for solution updates on my MSDN thread entitled "saved shared data source credentials lost after restart." Please post an update to the status that I can communicate to them as well, unless you are going to post the update there too.
Posted by bbb1 on 9/25/2009 at 9:24 AM
What is the status of this bug? I am really getting tired of retyping my user/password and checking the save password box (to no avail) every day for every project that I am working on.
Posted by rschmitz on 5/22/2009 at 10:18 AM
Yes, I open BIDS (Visual Studio Team System on my computer) locally. I use this program to work on the report project including the data sources, and I preview the reports locally before deploying them to the report server.
I have used two methods to store credentials in the shared data sources. The first is to enter a specific user name and password into the Credentials tab of the data source properties window. The second is to use the Edit button on the General tab of the data source properties window and enter a SQL Server Authentication user name and password with the Save my password box checked.
By restarting the machine, I mean physically shutting down and restarting my local computer. The problem does not occur if I just restart BIDS.
Thanks again for your help. Let me know if you need more information.
Posted by Microsoft on 5/21/2009 at 12:05 PM
Thank you for the details. A few clarifications please.
You workflow involves BIDs (Business Intelligence Development Studio) locally, correct? By this I mean you create reports and shared data sources in a BIDS reporting project, preview them locally (vs publishing to a report server)?
When you say you permanantly save credentials, what specific actions are you taking in the UI?
When you say you restart the machine..does the same thing happen if you restart just BIDS, or it has to be a physical machine restart?

Posted by rschmitz on 5/20/2009 at 10:47 AM
Thanks for looking into this problem so promptly.
I do not have permissions to create a new project in Source Safe, but I did create a new project outside of it with a new report and data source. The behavior is slightly different, but the problem is still present. I made sure I stored the data source credentials to be saved permanently before restarting. When I try to preview the report after a computer restart, the report is loaded and displayed with no problems. However, I receive an an error that the data source credentials are invalid or missing when I access the Data screen of the report.
The problem behavior remains exactly the same when I exclude a report from Source Safe, restart the computer, and access the Preview or Data screens for the report. I made sure I stored the data source credentials to be saved permanently before restarting, but I receive an error that the data source credentials are invalid or missing after a computer restart.
Posted by Microsoft on 5/19/2009 at 8:20 AM
Thank you for using SQL Server Reporting Services
This issue is being investigated.
If you create a new solution,report, and a new shared data source does the same issue occur?
Is it possible to test one of the exisitng reports but with source safe taken out of the environment, just for that report/solution?
Thank you.
Sign in to post a workaround.