Home Dashboard Directory Help
Search

WF 4.0 - “Open Clipboard Failed” error when attempting to copy a sequential workflow. by Alan Smith MVP


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


1
0
Sign in
to vote
Type: Bug
ID: 521321
Opened: 12/19/2009 1:10:47 AM
Access Restriction: Public
0
Workaround(s)
view
1
User(s) can reproduce this bug

Description

When attempting to copy the activities from a fairly simple WCF Workflow Service a dialog box pops up with the error message:

“Open Clipboard Failed (Exception from HRESULT: 0x800401D0 (CLIPBRD_CANT_OPEN)”

I have not managed to find a cause for this, but will investigate further.
Details
Sign in to post a comment.
Posted by Lem O. Ejiogu on 12/11/2012 at 1:44 PM
WHY HAS N'T MICROSOFT CORP. SOLVE THIS PROBLEM TILL NOW?

"TILL NOW" because, I have been experiencing it since 2010. Sometime, repeatedly over a whole session od computing.

Along with it is the more oftener problem of SEND ERROR TO MICROSOFT.

ITS WORST AGGRAVATION ON PRODUCTIVITY IS WITH PROCESSING LARGE FILES [e. g., 2.5MG] AND WORSE THAN THAT IS COPYING OFF-LINE DOCUMENTS OR PORTIONS THEREOF, TO ONLINE FILES FOR EMAILING. WITH SOME SUCH PROCESSES, I HAVE HAD TO WAITH DAYS/WEEKS WITH SHUTTING OFF THE COMPUTER.

i MUST COMMENT THAT THE MICROSOFT COMMENT ABOVE IS NOT ADDRESSING THIS TORTUOUS PROBLEM (BY MAKING IT SOUND LIKE IT DOES NOT EXIST).
.
Posted by antize on 9/25/2010 at 5:20 PM
Hi,

This happens more often than not to me using a function provided on PoshCode that sets the contents of the clipboard via PowerShell: http://poshcode.org/2219

I am trying this in an RDP session. Sometimes I get an exception, sometimes it works.

Exception calling "SetText" with "1" argument(s): "OpenClipboard Failed (Exception from HRESULT: 0x800401D0 (CLIPBRD_E_
CANT_OPEN))"
At line:8 char:41
+             [Windows.Clipboard]::SetText <<<< ($clipText)
    + CategoryInfo         : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : DotNetMethodException
Posted by Tim Lovell-Smith on 12/22/2009 at 3:47 PM
One more thing that could possibly have an effect - what was the last thing you copied onto the clipboard before you tried to copy the WCF service activities?
Posted by Tim Lovell-Smith on 12/22/2009 at 3:46 PM
Are you using the workflow designer on a virtual machine?
Are you using remote desktop?
Are you using any other program that may affect the clipboard while VS is running?
Posted by Microsoft on 12/22/2009 at 3:16 PM
Is this happening consistently? We haven't been able to repro this issue?

Thanks,
Kushal.
Posted by Microsoft on 12/21/2009 at 3:20 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.