Home Dashboard Directory Help
Search

ADO Command Parameters's Count is always zero for CLR stored procedure by budibong


Status: 

Resolved
 as External Help for as External


1
0
Sign in
to vote
Type: Bug
ID: 523803
Opened: 1/7/2010 3:09:36 PM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

After calling the Command->Parameters->Refresh(), the Parameters' Count is always zero (0) when working with CLR stored procedure (SP).
However, with T-SQL SP and command text such SELECT * FROM Table WHERE Field = ?, the Parameters' Count value shows the correct result.

Environment: VS2008, VC++, Unmanaged Code, ADO 2.8, SQL Server 2008.
Other property values:
Connection String = Provider=SQLNCLI10; Server=[specified]; Database=[specified]; Integrated Security=SSPI;

Details
Sign in to post a comment.
Posted by Microsoft on 1/25/2010 at 2:25 PM
Thanks for reporting this issue. After further investigation, we found that this bug belongs to a different team and it's being scheduled to be fixed in future releases.

Also, due to infrastructure reasons, we're closing this issue as EXTERNAL to be tracked in a different database. If you are blocked or experiencing issues du to this issue, please, feel free to reopen it or contact CSS for direct follow up.

Thanks
Luiz Santos
Program Manager
ADO.NET Managed Providers team
Posted by Microsoft on 1/12/2010 at 1:38 AM
Thank you for reporting the issue.

We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution.
These specialized experts will follow-up with your issue.
Posted by Microsoft on 1/8/2010 at 3:30 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.