Home Dashboard Directory Help
Search

CopyLocal not working in VS 2010 for unmanaged projects by cking_adify


Status: 

Closed
 as By Design Help for as By Design


4
0
Sign in
to vote
Type: Bug
ID: 561522
Opened: 5/25/2010 10:23:21 PM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

CopyLocal does not work in VS 2010 for unmanaged projects
Details
Sign in to post a comment.
Posted by Microsoft on 7/8/2010 at 1:57 PM
Hi,

Thanks for reporting this issue. You are right that it is only an issue with unmanaged projects. This is by design as Copy Local was designed only to work with assemblies and managed components. It does not work with unmanaged binaries. This is the same way it worked in VS2008 as well. Unfortunately we will not be able to fix this behavior for VS2010. To workaround the issue please use custom build steps to copy the binaries to the desired location.

Thanks,
Amit Mohindra
Posted by cking_adify on 6/6/2010 at 3:23 AM
Hello, thanks for forwarding the issue to the VS group. Have they triaged the bug?

I hear this is not a problem for managed .vcxproj files. Unfortunately I would like it to work with unmanaged .vcxproj files. For this latter scenario will they issue a patch or work around?

Thanks,
Chris
Posted by Microsoft on 5/27/2010 at 1:56 AM
Thanks for your feedback. We were able to reproduce the issue you are seeing. We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 5/26/2010 at 4:01 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
UnmanagedCopyLocal.zip 5/25/2010 8.08 MB