Home Dashboard Directory Help
Search

Visual Studio 2010 crashes on startup by wo80


Status: 

Active


8
0
Sign in
to vote
Type: Bug
ID: 567979
Opened: 6/16/2010 4:09:13 AM
Access Restriction: Public
1
Workaround(s)
view
8
User(s) can reproduce this bug

Description

This feedback is related to

https://connect.microsoft.com/VisualStudio/feedback/details/551032/visual-studio-ultimate-2010-crashes-on-windows-7-x64

Since I don't know, if older posts are monitored, I thought, I'll post a new one.

The problem is VS2010 (prof. edition on win7 x64) crashing on startup without any further error messages. The windows eventlog shows

Application: devenv.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException
Stack:
at MS.Internal.Text.TextInterface.Native.Util.ConvertHresultToException(Int32)
at MS.Internal.Text.TextInterface.FontFace.TryGetFontTable(MS.Internal.Text.TextInterface.OpenTypeTableTag, Byte[] ByRef)
[...]

Crashdump can be found at

http://cid-45ee4c562b38fc34.office.live.com/browse.aspx/.Public/VS2010%5E_Crash

I get the same error in the windows eventlog, when trying to start the new help library manager (actually, the manager didn't cash but showed a message box "Unknown error ..." with no useful information).

Doing a repair install of VS2010 didn't help.


To prevent VS from crashing:

I compared the installed fonts with the list at

http://www.prepressure.com/fonts/basics/windows-7-font-handling/list

and deleted all fonts that weren't listed there (after a backup of course). This solved the problem with VS but may cause problems with other programs.
Details
Sign in to post a comment.
Posted by cucucucu on 3/14/2014 at 1:04 AM
In any situation where there are corrupt fonts, all WPF application crash completely and the fonts that cause the issue are often very hard to find. Users are obviously blaming the WPF developers, but the one to blame is Microsoft. Yet Microsoft says that this bug is not important enough to solve. Please explain. This is a huge bug in WPF affecting all WPF users. Corrupt fonts often occur on system and should not crash just any WPF application.
Posted by Microsoft on 7/22/2012 at 10:03 PM
The WPF team has recently reviewed this issue and will not be addressing this issue as at this time the team is focusing on the bugs impacting the highest number of WPF developers. If you believe that this was resolved in error, please reactivate this bug with any necessary supporting details.
Posted by Bob Strunz on 1/28/2011 at 2:35 AM
I have a similar problem, as soon as I load my project the IDE crashes. It was working fine then suddenly it went badly wrong. The Application event log is as below. OS is Windows 7 x64 on six processors, settiing devenv to use a single processor does not help matters.


Problem signature:
P1: devenv.exe
P2: 10.0.31118.1
P3: 4ce50c95
P4: mscorlib
P5: 4.0.0.0
P6: 4cd2405b
P7: 1eb3
P8: 21
P9: System.ArgumentOutOfRange
P10:
Posted by nagual on 6/21/2010 at 12:14 AM
I think this is related to the fact, that .net 4 is not installing the WPF Font cache service for .net 4 on Win 7 64 Bit.
Posted by Microsoft on 6/16/2010 at 6:53 PM
Thank you for reporting the issue.
We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution.These specialized experts will follow-up with your issue.
Posted by Microsoft on 6/16/2010 at 5:02 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
Posted by Marc Tidd on 6/29/2010 at 1:03 PM
I have this issue also with VS 2010 on Windows 7. I have not yet tried deleting fonts.

Disabling the Windows Fonts Cache Service allows VS 2010 to run.