Home Dashboard Directory Help
Search

Install of KB983504 fails for TFS2010 by magra


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


1
0
Sign in
to vote
Type: Bug
ID: 625622
Opened: 11/30/2010 2:06:33 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

I get a fatal error during installation of the hotfix KB983504 when installing on a Windows 2008 R2 x64 server that has TFS2010 RTM installed. I have successfully installed this hotfix on a client PC, so it seems it is just the server PC that has a problem.

Here is a fragment of the MSI log:

MSI (s) (B4:9C) [09:24:31:554]: Product: Microsoft Team Foundation Server 2010 - ENU - Update 'KB983504' could not be installed. Error code 1603. Additional information is available in the log file C:\Users\hughal01\AppData\Local\Temp\2\KB983504_20101130_092401086-Microsoft Team Foundation Server 2010 - ENU-MSP0.txt.

MSI (s) (B4:9C) [09:24:31:578]: Windows Installer installed an update. Product Name: Microsoft Team Foundation Server 2010 - ENU. Product Version: 10.0.30319. Product Language: 1033. Manufacturer: Microsoft Corporation. Update Name: KB983504. Installation success or error status: 1603.

MSI (s) (B4:9C) [09:24:31:579]: Note: 1: 1729
MSI (s) (B4:9C) [09:24:31:579]: Product: Microsoft Team Foundation Server 2010 - ENU -- Configuration failed.

MSI (s) (B4:9C) [09:24:31:579]: Windows Installer reconfigured the product. Product Name: Microsoft Team Foundation Server 2010 - ENU. Product Version: 10.0.30319. Product Language: 1033. Manufacturer: Microsoft Corporation. Reconfiguration success or error status: 1603.

MSI (s) (B4:9C) [09:24:31:580]: Attempting to delete file c:\Windows\Installer\192478c0.msp
MSI (s) (B4:9C) [09:24:31:580]: Unable to delete the file. LastError = 32
MSI (s) (B4:9C) [09:24:31:582]: Deferring clean up of packages/files, if any exist
MSI (s) (B4:9C) [09:24:31:582]: Attempting to delete file c:\Windows\Installer\192478c0.msp
MSI (s) (B4:9C) [09:24:31:584]: MainEngineThread is returning 1603
MSI (s) (B4:8C) [09:24:31:585]: No System Restore sequence number for this installation.
=== Logging stopped: 30/11/2010 09:24:31 ===

I want to install this hotfix so I can get the Branch from label functionality. After installing the hotfix on the client, I get the Label option in the branch dialog, but on executing the command I get a TF203035 error. I assume this is due to the server part not getting installed.
Details
Sign in to post a comment.
Posted by magra on 1/14/2011 at 3:17 AM
By the way, initially I did have issues with KB983578 though I resolved them. Sorry, I can't quite remember the details of how - I expect it was a permissions problem.
Posted by magra on 1/14/2011 at 3:16 AM
No, I failed to get this particular KB to install however I found a later update (KB983578) which did install correctly so with that and the pending SP1 release, I don't think I will encounter this problem again. Thanks.
Posted by Microsoft on 1/13/2011 at 7:38 AM
We are sorry you are having problems installing Team Foundation Server hotfixes. Do you still have the same problem? If so, can you please send the TFS configuration logs? You can find the configuration logs by opening the Team Foundation Server Administration Console and clicking the "Logs" node.
Posted by magra on 12/3/2010 at 1:06 AM
Note that the same problem also occurs on the slightly newer KB983578 installer.
Posted by Microsoft on 11/30/2010 at 11:09 PM
Thanks for your feedback.
We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 11/30/2010 at 2:20 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
KB983504_20101130_092401086-Microsoft Team Foundation Server 2010 - ENU-MSP0.txt 11/30/2010 1.29 MB