Home Dashboard Directory Help
Search

Siverlight isn't working all the sudden?? by LovedByTheStarBreather


Status: 

Closed
 as Fixed Help for as Fixed


1
1
Sign in
to vote
Type: Bug
ID: 686307
Opened: 8/30/2011 10:45:28 PM
Access Restriction: Public
Moderator Decision: Sent to Engineering Team for consideration
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

I had been using my PC to watch Netflix since around the beginning of the year, so several months now. Siverlight came installed on my PC so I never had to worry about it. I used Netflix every day and it always worked just fine, never any problems.

Then about a month ago, I went to play Netflix as I always do but it wouldn't let me watch anything because it said I needed to download the Siverlight Plug-in. It was really random because nothing had ever changed, so it was weird to suddenly get this warning out of the blue after so many months. I figured Siverlight must have updated or something, so I went through the steps to download it. But when I got to the very end of all the downloading process, it says "Siverlight cannont be installed because the same version of Siverlight already exists on this computer."

So I went into my computer programs and uninstalled everything connected to Siverlight I could find and tried to download it again. It let me download it that time, but Netflix still says I need Siverlight to watch anything. I even tried downloading the latest version of Siverlight straight from the Microsoft website rather than using the link Netflix gave me in case something was messed up with the link but it still didn't make a diference.

I thought maybe it was a problem with Netflix but when I requested help for it, they said Netflix was working fine and diagnosed it as a problem with Siverlight.

I'm really stuck because it won't let me watch Netflix without downloading Siverlight first, but it wont let me download it because I already have it. How would I go about fixing this problem?? Any help would be greatly appreciated as I am getting really frustrated not being able to watch anything on my PC for so long!
Details
Sign in to post a comment.
Posted by muzikgurl on 4/29/2014 at 4:52 PM
It didn't work for me. Im having the same problem. Everything was already as it should have been.
Posted by Microsoft on 9/19/2011 at 2:50 PM
Hello,

I haven't heard back from you since I posted my response a few weeks ago. I'm going to assume that my comments have helped you get Silverlight going again and will resolve this bug as fixed.

Thanks

Andy Rivas
Silverlight
Posted by Microsoft on 8/31/2011 at 2:17 PM
Hello,

1. Make sure the Silverlight plugin is enabled. From IE, go to the Tools menu (Alt+T), select the Add-on settings menu item, and look for the "Microsoft Silverlight" plugin in the dialog. Verify Microsoft Silverlight is enabled.

2. Make sure IE9 ActiveX Filtering is disabled. From IE9, go to the Tools menu (Alt+X), select the Safety submenu, and look for the "ActiveX Filtering" menu item. Verify it is unchecked.

3. Silverlight content does not run on 64-bit browsers. If you are using IE on an x64 system, you absolutely need to be using 32-bit IE to view SL pages.

How to tell which bitness IE you are running:
•The Help | About.. dialog in 64-bit IE says "64-Bit Edition", while the 32-bit IE doesn't have that tag.
•In the list of programs on your Start Menu, the 32-bit IE shortcut is "Internet Explorer" while the 64-bit IE shortcut is "Internet Explorer (64-bit)".
•The full pathname to 32-bit IE is c:\program files (x86)\Internet Explorer\iexplore.exe, while the full pathname to 64-bit IE is c:\program files\Internet Explorer\iexplore.exe.

Let me know if any of these solve your issue.

Thanks!

Andy Rivas
Silverlight
Posted by MS-Moderator08 [Feedback Moderator] on 8/31/2011 at 2:49 AM
Thank you for submitting feedback on Visual Studio 2010 and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by MS-Moderator01 on 8/30/2011 at 11:42 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.