Home Dashboard Directory Help
Search

Incorrect time listed by Mrichmon


Status: 

Closed
 as Fixed Help for as Fixed


1
0
Sign in
to vote
Type: Bug
ID: 774052
Opened: 12/11/2012 10:49:48 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

In TFS (VisualStudio.com) we have our settings for Timezone set to Pacific. However, the times listed for all versions in check-in history are clearly not Pacific time (i.e. I did not do all my checkins between 1am and 6am
Details
Sign in to post a comment.
Posted by Mrichmon on 12/21/2012 at 9:27 AM
Thank you that is helpful!
Posted by Microsoft on 12/21/2012 at 9:25 AM
Thanks for reporting this issue. This bug was introduced in our last deployment and we caught it just a little too late. The duplicate bug was an internally filed bug that we had already fixed. This fix will get pushed out in the next update to our service. Apologies for the poor communication here from our tooling - that is my fault. I did not realize that resolving a customer Connect bug in our system as Duplicate would not provide any further details. I should have resolved it as fixed. Anyways, you should see this issue fixed after our next service update.

Thanks again,
Nick
Posted by Mrichmon on 12/21/2012 at 9:06 AM
This was just marked as "Resolved" and "Duplicate", but no info as to where the duplicate is. I have been responding to each comment, providing feedback and screenshots as requested. The least you can do is respond with where the duplicate issue is so I can track it and see when it is fixed....
Posted by Microsoft on 12/20/2012 at 12:10 PM
Thanks for the quick response! We'll have someone look into this soon.

Thanks,
Taylor
TFS Version Control
Posted by Mrichmon on 12/20/2012 at 9:24 AM
The issue is only in the web view. It appears correct for the VS client.

I have attached screenshots for vs.com timezone setting, local machine timezone setting, incorrect time in vs.com for history of changesets.
Posted by Microsoft on 12/20/2012 at 7:46 AM
Thanks for filing this issue. Are you seeing these issues in both the VS client and the web views for history? It would be helpful to see attachments with screenshots of both views for the same changeset. A screenshot of your timezone setting in VS.com and the local machine would be useful as well.

Thanks,
Matt
Program Manager | TFS Version Control
Posted by Microsoft on 12/12/2012 at 12:17 AM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Mrichmon on 12/11/2012 at 11:54 AM
After more testing it appears that the timezone being used is UTC +8 (China) instead of UTC -8 (Pacific)
Posted by Microsoft on 12/11/2012 at 11:51 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
vs.com-changesets.gif (restricted) 12/20/2012 -
vs.com.gif 12/20/2012 4 KB
localmachine.gif 12/20/2012 14 KB