Home Dashboard Directory Help
Search

No Intellisense in XAML Editor in Visual Studio 2012 by Ted Weston


Status: 

Closed


1
0
Sign in
to vote
Type: Bug
ID: 777863
Opened: 1/30/2013 3:14:09 AM
Access Restriction: Public
1
Workaround(s)
view
0
User(s) can reproduce this bug

Description

When I originally installed VS2012 I'm sure Intellisense worked OK but there was an update to VS2012 yesterday which seems to have removed Intellisense from the XAML editor.

The version of VS2012 Professional is 11.0.50727.1 RTMREL

I look forward to a speedy response.
Details
Sign in to post a comment.
Posted by Microsoft on 2/1/2013 at 12:35 AM
Thanks for your feedback. Based on your description, I will close this issue. If at any time your issue is closed unsatisfactorily, you may edit your issue via Connect and change the status to “Active.”
Posted by Ted Weston on 1/31/2013 at 6:28 AM
Thanks for your response. By changing the Target Framework in the project's properties to .NET4 , Intellisense now works correctly.

The project was originally developed in an earlier version of VS and the target framework was set to .NET 3.5. I felt sure that Intellisense did work initially but maybe I was mistaken (which is of course, quite possible!).

Maybe this should be brought to the attention of others who are planning to upgrade to VS2012, which on initial findings is excellent.

Keep up the good work.
Posted by Microsoft on 1/30/2013 at 8:37 PM
Thanks for reporting the issue.

In order to fix the issue, we must first reproduce the issue in our labs. We are unable to reproduce the issue with the steps you provided.

Please export and reset environment settings file by clicking Tools-> Import and Export Settings. If this issue does not persist after that, please zip the settings file and send it to us so that we can conduct further.

Please try this (from a Visual Studio command prompt with devenv in the path):

devenv /resetuserdata

It would be greatly appreciated if you could provide us with that information as quickly as possible. If we do not hear back from you within 7 days, we will close this issue.

Thanks again for your efforts and we look forward to hearing from you.
Microsoft Visual Studio Connect Support Team
Posted by Microsoft on 1/30/2013 at 3:49 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
Posted by Ted Weston on 1/30/2013 at 3:24 AM
I've done some more "digging" and found that the following fixes the problem.


I had the same issue, no intellisense in any XAML. What I ended up doing was switching the target framework from .NET Framework 4 Client Profile to .NET Framework 4. After that, Intellisense worked again.