Home Dashboard Directory Help
Search

Visual Studio 2012 becomes highly unstable when having multiple tab groups by BIGsheep


Status: 

Closed


2
0
Sign in
to vote
Type: Bug
ID: 778717
Opened: 2/7/2013 12:30:38 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

After using Visual Studio 2012 for several months now I'm having to change the way I work due to the instability of its abilty ot handle multiple tab groups. If I split the main window into two to display two sets of files, or even drag out a file to create a floating set of tabs, there is a greatly increased chance of VS crashing.

The crash seems to happen most when I attempt to cut and paste for some reason though is liable to crash at random times when inactive, typing, or going to definitions.

When working without tabs I find the frequency of crashing drops noticably. With tabs its been known to crash 10 times in an hour. Without, I haven't had one in the last two days.
Details
Sign in to post a comment.
Posted by Microsoft on 4/29/2014 at 12:30 PM
Thank you for reporting this issue. This issue has been fixed in Visual Studio 2013. You can install a trial version of Visual Studio 2013 with the fix from: http://go.microsoft.com/?linkid=9832436
Posted by BIGsheep on 3/20/2013 at 1:26 AM
Will do.

Currently our VA license has lapsed but we're seeking renewal and as soon as that happens I'll give it a thorough test :)

Thank you.
Posted by Microsoft on 3/18/2013 at 7:15 PM
I've confirmed that the reported problem is a known issue with 10.7.1916. Visual Assist has resolved the issue with 10.7.1918. Please install the update. If you continue to see this issue, please open a new connect bug. Thank you.

Art Leonard
Visual Studio IDE Team
Posted by Microsoft on 3/17/2013 at 11:48 PM
Have you installed the latest build form Visual Assist? http://www.wholetomato.com/support/history.asp Their statements claim their changes should address issues causing crashes that occur after applying window layout changes.
Posted by BIGsheep on 3/5/2013 at 12:07 AM
I'd be more than happy to help. If there's anything I can do please don't hesitate in contacting me. Please let me know how you'd like me to pass on my email details.
Posted by Microsoft on 3/4/2013 at 11:33 PM
Hello,

Thank you for contacting us.

We have looked at your issue, and it appears to be related to using Visual Assist. We are interested in resolving this issue, as this particular issue is not unique, however we have not been able to replicate the conditions for the crash. Would you be willing to help us by allowing us to work directly with you and the Visual Assist (Whole Tomato) team to help resolve this issue via email?

Thank you,
Art Leonard
Visual Studio IDE Team
Posted by Microsoft on 2/14/2013 at 6:50 PM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 2/13/2013 at 1:00 AM
Hi BIGsheep,

Thank you for your quick response. I have read your file, but there is no dump file in them. Can you try to get dumps for devenv process? Try attaching WinDbg or use DebugDiag 1.2 to get a dump for devenv and see what is cauing this issue. http://www.microsoft.com/en-us/download/details.aspx?id=26798
Posted by BIGsheep on 2/12/2013 at 8:38 AM
Splendid. Cheers for that. I uploaded the troublesome four I spoke of at the start of the day and just sent another 10 crash reports that happened today.
Posted by Microsoft on 2/11/2013 at 11:02 PM

Hi BIGsheep,

I am sorry for the inconience.

Please go to
C:\Users\[User]\AppData\Local\VSFeedbackTool\Feedbacks to get the file.

Please zip the file and use "FeedbackID-778717" as prefix of the file name.

You can use the following workspace to upload the file:
https://sftus.one.microsoft.com/choosetransfer.aspx?key=e150d860-62e0-45dc-b169-fc1e1d0650d7
Password is #HaqmwwA{D_M)D

Thanks again for your efforts and we look forward to hearing from you.

Microsoft Visual Studio Connect Support Team
Posted by BIGsheep on 2/7/2013 at 2:15 AM
I have installed the plugin and have attempted to provide four lots of feedback this morning but each time the tool itself complains that there are either network issues or the files that are attached might not be my own.
Posted by Microsoft on 2/7/2013 at 1:14 AM
Thanks for your feedback. In order to efficiently investigate and reproduce this issue, we are requesting additional information outlined below.

Could you please give us dump of this issue so that we can conduct further research?

Visual Studio now has an extension called Visual Studio 11 Feedback Tool , available on the VS gallery(http://visualstudiogallery.msdn.microsoft.com/f8a5aac8-0418-4f88-9d34-bdbe2c4cfe72).

The extension allows you to
1.    upload files,
2.    collect trace and dump files
3.    collect steps while you're repro'ing the issue, as well as
4.    SQM logs about VS extensions installed
5.    System details (in DxDiag output)


We look forward to hearing from you with this information.

Microsoft Visual Studio Connect Support Team
Posted by Microsoft on 2/7/2013 at 12:50 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.