Home Dashboard Directory Help
Search

Incorrect output when evaluating std::ratio_equal<> by wardw6


Status: 

Closed


1
0
Sign in
to vote
Type: Bug
ID: 788745
Opened: 5/28/2013 3:56:52 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

As title. See code example.

Apologies if this is fixed in Update 2, not tested. Mind, I couldn't see any other reference to this.
Details
Sign in to post a comment.
Posted by Microsoft on 4/29/2014 at 12:30 PM
Thank you for reporting this issue. This issue has been fixed in Visual Studio 2013. You can install a trial version of Visual Studio 2013 with the fix from: http://go.microsoft.com/?linkid=9832436
Posted by Microsoft on 7/1/2013 at 4:19 PM
Hi,

Thanks for reporting this bug. We've overhauled <ratio> to fix this and many other bugs. These fixes will be available in VS 2013 RTM (but not Preview).

Note: Connect doesn't notify me about comments. If you have any further questions, please E-mail me.

Stephan T. Lavavej
Senior Developer - Visual C++ Libraries
stl@microsoft.com
Posted by Microsoft on 5/29/2013 at 2:24 AM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 5/28/2013 at 4:50 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.