Home Dashboard Directory Help
Search

Property Pages -> Configuration Properties -> Debugging -> Environment setting fails by Dan Nissenbaum


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


1
0
Sign in
to vote
Type: Bug
ID: 794268
Opened: 7/17/2013 10:03:59 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description


Hello. There seems to be a bug with the Visual Studio 2012 C++ debugger.

When a project's Property Pages -> Configuration Properties -> Debugging -> Environment setting is used to update the PATH via PATH=NewPath\;%PATH%, the updated path is not available in the debugee.

I have carefully looked through forums, and this is a known issue from the past that has supposedly been fixed (see https://connect.microsoft.com/VisualStudio/feedback/details/695051/debugging-environment-variable-not-working).

However, the problem currently exists in Visual Studio 2012 as of July 17, 2013.

I cannot find any current discussion of the issue.
Details
Sign in to post a comment.
Posted by Microsoft on 7/31/2013 at 6:37 PM
Hello Dan,

Thank you for reporting this. I just tried modifying the PATH in the Environment Settings with the latest 2013 build and it looks like it has been fixed in the latest version. You can try out 2013 Preview for yourself and see if this issue has been fixed for you as well.

Thanks
Posted by Microsoft on 7/17/2013 at 9:47 PM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 7/17/2013 at 10:50 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.