Home Dashboard Directory Help
Search

Visual Studio 2013 Hangs and show Waiting for a required operation to complete by Data Juggler


Status: 

Closed
 as Fixed Help for as Fixed


82
1
Sign in
to vote
Type: Bug
ID: 806673
Opened: 10/26/2013 10:42:39 AM
Access Restriction: Public
1
Workaround(s)
view
45
User(s) can reproduce this bug

Description

This has happened so many times, I have to use Task Manager to close Visual Studio (2013); This is the full version Ultimate;

It seems to happen when I clicked text to select, but now it happens when I open a project or anything; I really can't use this product and be productive.

This was happening before I installed the beta of Installshield LE 2013, but it seems to happen more since, I may uninstall it and see if that is the culprit, but I had encountered this many times before installing Installshield LE Beta 2013

At least have that operation window have a recovery option to cancel the operation or something.

Details
Sign in to post a comment.
Posted by chaspc on 7/18/2014 at 1:31 PM
Definitely not "fixed". I cannot click on one of my forms to edit it without getting the "Visual Studio is Busy" message. This form is an integral part of my product and now I cannot access it.

Microsoft Visual Studio Professional 2013
Version 12.0.30501.00 Update 2
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional

LightSwitch for Visual Studio 2013 06177-004-0444002-02563
Microsoft LightSwitch for Visual Studio 2013

Office Developer Tools - May 2014 Update ENU 06177-004-0444002-02563
Microsoft Office Developer Tools for Visual Studio 2013 - May 2014 Update ENU

Team Explorer for Visual Studio 2013 06177-004-0444002-02563
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013 06177-004-0444002-02563
Microsoft Visual Basic 2013

Visual C# 2013 06177-004-0444002-02563
Microsoft Visual C# 2013

Visual C++ 2013 06177-004-0444002-02563
Microsoft Visual C++ 2013

Visual F# 2013 06177-004-0444002-02563
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker 06177-004-0444002-02563
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Windows Phone SDK 8.0 - ENU 06177-004-0444002-02563
Windows Phone SDK 8.0 - ENU

Advanced Installer Extension 11.2.1
Advanced Installer Extension. For more information visit the Advanced Installer website at www.advancedinstaller.com. Copyright © Caphyon LTD. All rights reserved.

ASP.NET and Web Tools 2013.2.50425
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

ASP.NET Web Frameworks and Tools 2012.2 4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013 5.1.20409.0
For additional information, visit http://www.asp.net/

Common Azure Tools 1.1
Provides common services for use by Azure Mobile Services and Windows Azure Tools.

NuGet Package Manager 2.8.50313.46
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer 1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools 12.0.30919.1
Microsoft SQL Server Data Tools

Windows Azure Mobile Services Tools 1.1
Windows Azure Mobile Services Tools

Windows Phone 8.1 SDK Integration 1.0
This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

Workflow Manager Tools 1.0 1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin 3.0.54.0 (d3cf238e3845e930e312b6ec9b4c6c5437c33067)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android

Xamarin.Android 4.12.00028 (98634deb)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS 1.8.365 (8cb9dbd0)
Visual Studio extension to enable development for Xamarin.iOS
Posted by EricRichards-Instant on 7/17/2014 at 5:48 AM
Certainly not "Fixed". I'm getting this consistently after adding a new Form to a C# project, and then re-sizing that form from the default size. It'd be nice if the dialog gave some indication of what was actually happening in the background and locking up the UI.
Posted by Alberto León on 7/9/2014 at 11:47 PM
For me It was sufficient to disable only a third party extension. The official microsoft extension are not necessary to be desabled.
Posted by ssDrone on 7/3/2014 at 12:56 PM
Update: I disabled (not uninstalled) all extensions and re-enabled them one by one. The problem just disappears!
Posted by ssDrone on 7/3/2014 at 11:04 AM
Visual Studio 2013 Update 2 does NOT fix the problem! Whenever any part of a form on a designer tab is clicked, "Waiting for a required operation to complete..." is flashing continuously at the bottom left corner of VS2013 for ~5 minutes while VS2013 freezes. Eventually VS2013 crashes and restarted. Repairing Update 2 does not help either.
Posted by Microsoft on 6/6/2014 at 9:54 AM
Thank you for using Visual Studio and for reporting this bug. We are happy to let you know that this issue has been fixed in Visual Studio 2013 Update 2. If you already have Visual Studio 2013, you can upgrade to Update 2 for free or you can install a trial version from: http://go.microsoft.com/?linkid=9832436
Posted by John 09 on 5/30/2014 at 5:04 PM
My VS 2013 was Not Responding with "VS 2013 is busy ... " when I opened a CSS file and just clicked in it.

VS would just hang for over an hour before I finally gave up and restarted the machine - twice.

Note: I had VS 2013 Update 2 installed just after it was released- but the problem started yesterday, not prior to the Update 2. So based on that experience, I would say Update 2 does not solve the issue.

However, I disabled the extension Web Essentials 2013 for Update 2 - and VS 2013 is behaving so far.
Posted by compuaid on 5/28/2014 at 8:42 AM
Further discovery shows that in my instance the issue was caused by the remote FTP server terminating the connection when attempting to retrieve the directory listing. While the issue was caused by unexpected behavior at the server the fact that Visual Studio locks up with "Required Operation Waiting to Complete" is still a major problem. There should be a graceful response from VS to a connection error in FTP.
Posted by compuaid on 5/28/2014 at 8:02 AM
I just installed the RTM version of Update 2 and I'm no longer able to open my solution. Whenever I attempt to load the Default.aspx page the program hangs "Getting file 'Default.aspx' and I am forced end task Visual Studio. I'm afraid I'll have to uninstall and drop back to Update 1 which did not have this issue. This is a serious bug!
Posted by Jürgen Bayer on 5/22/2014 at 7:54 AM
For me this issue happens very frequently with Windows.Forms projects after opening the forms designer or (if opening the designer did not freeze VS) when clicking on a control.
I installed Update 2 RTM but that did not help. Instead I have the feeling that it made the problem worse.
Posted by TrendMicro on 5/15/2014 at 1:40 AM
How about the bug, when I debug device of windows phone 8.1 app it happens.
Posted by tmarcis on 4/24/2014 at 11:04 AM
In regard to my previous posting, a possibly relevent detail:

--- some, perhaps, many of the project references were to projects that were "unloaded" when the error occurred.
Posted by tmarcis on 4/24/2014 at 11:01 AM
I do not know if this pertains to the same issue, but today I started to get this same error message "waiting for an operation to complete" after just
clicking on a Windows form button. This was followed by ever-increasing Visual Studio memory consumption and subsequent program crash.

I had tried reinstalling Update 2 RC, but that had no effect.

I was able to identify this problem and resolve it in the following way. Someone had changed the all the project references in the project to "copy local" (<private>True</private> in the csproj file).
Both those projects and the referencing project had the same output directory as the target build directory, which would seem to cause a file conflict: but in this case I was not building, just
working in the Windows Forms designer. (If it matters at all, I believe this form uses DevExpress Windows Forms controls, but can't verify if that's relevant.)

Once I changed the all the "copy local" project reference settings to false (<private>false</private> in the csproj file), I was able to work in the form designer
and no "waiting for operation" message was generated.

It seems that a file-access conflict check might avoid this error.


Posted by Microsoft on 4/15/2014 at 3:54 PM
For performance issues, please see http://blogs.msdn.com/b/calvin_hsia/archive/2014/01/14/10406209.aspx and create a new issue along with a performance trace.

Thanks
Carl Brochu | VS Team
Posted by jairoenriquemartinez on 4/15/2014 at 7:22 AM
I have updated to Visual Studio 2013 Update 2 RC but I still have the issue.
Please let me know if you need any more information in order to resolve it.
Thanks.
Posted by Microsoft on 4/14/2014 at 3:16 PM
Please find the Visual Studio 2013 Update 2 RC here: http://www.microsoft.com/en-us/download/details.aspx?id=42307 in order to fix this issue. If you still see the problem with this update, please let us know

Thanks
Carl Brochu | VS Team
Posted by jasonracey on 4/9/2014 at 4:31 PM
I'm encountering this problem several times per day. Sometimes VS completes whatever it's doing but sometimes not - then I have to resort to killing the devenv process. I wait about 30-60 seconds before doing this. Here's my basic info:

Microsoft Visual Studio Professional 2013
Version 12.0.30110.00 Update 1
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Posted by LirazRom on 4/8/2014 at 2:31 PM
I have installed Update 2 RC, and cannot work with VS any more, save a file takes 30sec, sometimes stop of debugging the vs stop responding

Looks like i am going to uninstall completely VS2013 and reinstall it again with out the update
Posted by rh0dekyl on 4/6/2014 at 7:20 PM
It seems I have the same problem. I've got 2013 Premium, with update 1 installed. I'm also using the Nov2013_CTP. When I open up an existing project now the GUI hangs indefinitely (I just let it run over the weekend to see if it ever came back). The IDE is completely unusable at this point.
Posted by BillInPA on 4/4/2014 at 8:16 AM
This item is marked as Fixed, yet in the Visual Studio 2013 Update 2 RC its not mentioned as a fixed item
This is a serious problem costing many folks time and work
Will the fix be in Update 2?

Posted by Vincent_Thorn on 4/3/2014 at 10:04 AM
My env is: Win7 x64, VS 2013 Upd1. Before "Update1" everything was fine. But after "update" editor behaves wrong: from time to time (probably, after copy/paste operations) it freezes with the message "Waiting for a required operation to complete". It hangs for about 30 sec.
Posted by Rob de Voer on 3/23/2014 at 4:38 PM
I run VS Ultimate 2013 12.0.30110.00 Update 1 and the issue is still there. It occurs several times a day that in the C# editor I: select text, copy/paste text, or cut/paste text and the dreaded box comes up for seconds or minutes.
Posted by FryHard on 3/18/2014 at 6:28 AM
Also running VS2013 Ultimate Update 1 and the issue persists.
Posted by Radio7733 on 3/6/2014 at 3:21 PM
I have been unable to run VS2013 Express for Desktop as it hangs at startup.
Posted by BillMoller on 3/6/2014 at 9:28 AM
Excellent, thank you. I do have update 1, and the issue persists.
Posted by Microsoft on 3/4/2014 at 8:15 AM
We believe to have found the root cause of this issue and will be providing a fix in the next release of the Visual Studio 2013 update.

Thanks
Carl Brochu | VS Team
Posted by Data Juggler on 3/3/2014 at 4:17 PM
Yes it is fixed now, I applied Visual Studio 2013 Update 1 and I haven't had the problem.

I knew I wasn't the only one, but the 60 other replies convinced me it wasn't my environment.

Thank you for fixing it.
Posted by pdegenhardt on 2/27/2014 at 2:57 PM
Seeing the same problem with a large solution using a DSL. Problem seems to have disappeared now I have disabled Web Essentials.
Posted by spinin on 2/27/2014 at 7:18 AM
Just to tell you that VSExpress 2013 For Web hangs with this "Waiting for a required operation to complete" message on a W8 machine, but has no issues on W7. I uninstalled all .Net stuff and reinstalled form WPI, with no success. Also, VSExpress 2012 For Web doesn't run on W8.
Posted by BillMoller on 2/24/2014 at 1:32 PM
LMK if you need a better trace (with different options). I'm confident I can get the issue to reoccur ;)
Posted by Microsoft on 2/24/2014 at 12:29 PM
Thank you, Bill. We are actively working on a solution to this issue and your perf trace helps identify the root cause.

-Josh Stevens
VS IDE team
Posted by BillMoller on 2/24/2014 at 11:27 AM
ok, so I can reproduce this issue rather quickly. I ran PerfView with the standard switches plus "VS" (because I'm profiling VS, though again, I don't know what options I should be choosing). Also note, I took a heap snapshot "devenv.gcdump" WHILE the "Waiting for required operation to complete..." dialog was showing, and "devenv.1.gcdump" after Visual Studio returned control to me.

Due to limitations of the Connect Attachment system (<= 30 files, <= 50mb each, only certain types allowed...) I've attached a multipart (3 part) zip file... PerfView.zip is the first part. PerfView.part1.zip should be renamed back to PerfView.z01 and PerfView.part2.zip should be renamed back to PerfView.z02 (can't attach .z01, .z02 files)...
Posted by BillMoller on 2/24/2014 at 10:53 AM
MSFT, I will happily perform an ETL trace, but could you provide more concise information on how to acquire the trace you need. I do not have time to watch 2 hours of videos on how to use PerfView.

Specifically, I run PerfView with Command = "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe", but of the 30 or so other options, what should be selected? Do I stop after the hang happens? please advise...
Posted by BillMoller on 2/24/2014 at 10:41 AM
This also happens to me. Rather than just a "me too!" comment, it seems to happen most often when I *quickly* attempt a ctrl-c, ctrl-v copy paste... (it might just be happenning on the ctrl-C, as others have states, but I'm doing it so *quickly*, perhaps I'm assuming ctrl-v is also involved). It also happens CONSTANTLY when I open a solution when the Mindscape LightSpeed OR/M designer is the active window (open when I last closed the solution).
Posted by Jakob Hviid on 2/19/2014 at 2:50 AM
Hello.

I had this problem on my dekstop, but not on my laptop with one specific project. I wondered what the diffrence was and went through the extentions for visual studio 2013. It seemed the only diffrence on the desktop was Productivity Power Tools 2013. After disabling the plugin my project loaded just fine.

I would suggest others with this problem try and disable extra plugins for visual studio first.

Hope it helps.
Posted by Microsoft on 2/18/2014 at 3:55 PM
Hello, folks,

We're continuing to work through the issue. We're aware of the problem and are doing our best to isolate the issue and get a fix. ETL traces of the issue would be awesome if you could get them. http://channel9.msdn.com/Series/PerfView-Tutorial You can download PerfView from here: http://www.microsoft.com/en-us/download/details.aspx?id=28567

Thank you,
Art & Carl
Visual Studio IDE Team
Posted by Huckleberry32 on 2/18/2014 at 11:28 AM
I'm getting this too, when I select text and do cntl-C. Not every time, but frequently. It started 2 days ago. It has made Visual Studio 2013 unusable. I've gone back to VS 2012, which thankfully I hadn't uninstalled and is still an option for the project I'm on. This has been happening for several months now. Can we get an update from Microsoft on the status of this critical bug, and bump the priority up?
Posted by Jeff Sahol on 2/12/2014 at 8:00 AM
I had the same problem, only with one particular project, just as soon as I open it. After noticing that one of devenv's child processes was Microsoft.VisualStudio.Web.Host.exe, I was able to resolve the problem by editing each .csproj file and turning off UseVSHostingProcess. I am not sure what other side effects this will have, though.

This happened to me very soon after I reinstalled VS2013, downgrading from Ultimate to Premium. Maybe there is something left over from Ultimate (e.g., Intellitrace settings?) in these projects/solution, but I'd been working on this project on another box running Pro so I think not.
Posted by Lang Michael on 2/8/2014 at 6:03 AM
I have installed CTP 2 today but it had absolutely no effect.
Posted by Pieter_Veenstra on 2/6/2014 at 4:18 AM
Update 2 can be found here:

http://www.microsoft.com/en-us/download/details.aspx?id=41699
Posted by Pieter_Veenstra on 2/6/2014 at 4:16 AM
I just installed update 2 and the problem seems to have gone. At least my broken project is now loading again.
Posted by Frip28 on 2/5/2014 at 5:29 PM
I have the same problem, but this copy-paste problem is only in *.aspx, *.ascx, *.master page. I add anHtml page to my project, I can paste without any problem, I don't have any problem too with code file (in my case* .cs)

I just installed Update 1, thank the problem was resolved, but not, I have the same issue. I'm not on a professional project for this time, I just trying the new VS Studio and for the moment, this problem is a great productivity issue.

I don't know if could help, but on my labtop I have VS Studio 2012 and 2010 I use AnkkSVN for source control (with SVN of course).
Posted by BillInPA on 2/3/2014 at 1:04 PM
PS - It never came back - I had to taskman/end process on devenv.exe
Usually it does come back after 10 seconds to 1 minute, this time it did not
taskman processes showed 0 cpu
Posted by BillInPA on 2/3/2014 at 1:00 PM
See the procdump_devenv.zip I just uploaded - vs 2013, windows 7
It went into the state when I was adding a call to a non-existent member function, I was going to add the member function to a lower class in a few minutes
Posted by ScooterBrown1 on 2/2/2014 at 8:14 AM
Correction, I did have one single event (click) with no contents.
Posted by ScooterBrown1 on 2/2/2014 at 6:33 AM
Not sure of the relevancy, but I had the issue when I click a button on a simple winform. The button was the only control with nothing wired up to it. This was consistent 4 times that I opened the solution. Each time, I had to use the task manager to quit VS 2013, as it would accumulate up to 4 Gb of memory. The only way I got passed it, was to open a Windows Phone 8 solution that I have been working on, then open the winform solution. It was able to get passed the issue.

Since I couldn't sleep due to being wired on solving my serialization issue, I thought I would be productive. 2 hours later. ;) Happy now.
Posted by dcarapic on 1/29/2014 at 12:42 AM
I have just encountered the same problem. At some point cut operation in HTML editor just starts to block with familiar "Waiting for requested operation to complete ....". I am going to try to make a dump using procdump but it is not easy to reproduce the issue since it no longer appears.
Posted by Mark W-T on 1/28/2014 at 10:35 AM
Hi @firkinfedup

Your problem sounds more serious than those other folks on this thread have been describing. Sorry for the trouble you are seeing here.

To diagnose a crash like this, we need a crash dump. There are several ways to get hold of a crash dump, but here are a couple:
1.    Install procdump (http://technet.microsoft.com/en-us/sysinternals/dd996900.aspx). At the right time call “procdump.exe -ma devenv.exe c:\temp\devenv.dmp”. Upload devenv.dmp to us.
2.    Use Windows Task Manager, right click on VS and select “Create dump file”. This is less preferred as on 64bit machine it would create 64bit memory dump of VS process (which is 32bit app) – those are harder to work with and often corrupted.

If you can upload a crash dump from this issue it may enable us to isolate the issue.

Another interesting question is whether an extension is involved in your crash. To test this theory, try starting Visual Studio from the command line in safe mode:
http://msdn.microsoft.com/en-us/library/ms241278.aspx

Again, sorry for the trouble you are encountering here,
Visual Studio Editor Team
Posted by Firkinfedup on 1/28/2014 at 1:52 AM
I'm getting this just from opening Visual Studio now, no project loaded, hangs instantly. Tried closing via task manager 3 times, still persists. I thought it might of been the new start page that downloads a tonne of video thumbnails.
Posted by nunesb on 1/27/2014 at 4:31 AM
Seems to happen when you copy paste or select something. Also seems to happen when intellisense tries to open.
Posted by megawhite on 1/16/2014 at 2:46 PM
This is killing me too, multiple times today resulting in crashes.

I just attempted to paste about 30 lines of C++ code out of an HTML email in Outlook into an empty function body. The dialogue came up, went away but the status in the bottom left stayed with the message about waiting for the required operation to complete. UI completely locked, Task Manager end process job.

Sorry I do not have time to instigate an ETW Performance trace, hopefully this additional nugget of information may be helpful.
Posted by Microsoft on 1/13/2014 at 2:53 PM
Hello all.

In order to help us diagnose this issue, it would very much help to get an ETW Performance trace and a dump, so we can analyze what is causing the performance issues on your machines. So far nobody who is experiencing the problem has been able to provide such information, and without it we will not be able to make progress.

If you are seeing this problem, please go to http://visualstudiogallery.msdn.microsoft.com/en-us/e8649e35-26b1-4e73-b427-c2886a0705f4 to download the tool. Please read the installed "Performance Diagnostics Tool - User Guide" document on steps to generate a trace around your performance scenario, and on how to create a dump. Once these are created please let us know.

When you uninstall the tool, the settings.ini file will not be removed as it contains your user settings. Note that XP does not provide stacks for traces, so if possible please run this on Vista or Windows 7 or 8.

Thanks
Visual Studio Editor Team
Posted by teatime on 1/9/2014 at 3:31 PM
I to am repeatedly having this issue, so is there a fix in the works or what? Having DevEnv.exe taking 99% of my CPU after a few copy and pastes in the html editor. Its destroying all productivity and making my job extremely stressful, so much so that I would rather avoid doing any development at the moment.
Posted by KawaiiSoft on 1/7/2014 at 6:52 AM
Happens every time I start Visual Studio Express 2013. I have performed no action; I have to wait for the "required operation to complete" which takes several minutes, then Visual Studio performs normally.
Posted by Hossein Aarabi on 1/2/2014 at 11:11 AM
"Visual Studio now has an extension called Microsoft Visual Studio 2013 Feedback Tool, available on the VS gallery(<http://visualstudiogallery.msdn.microsoft.com/563d1003-f0ed-498f-8ef9-f8ee1aac39fe>)"

How are supposed to use that extension when Visual Studio locks up.

This is a major bug.
Posted by gillesv38 on 1/1/2014 at 9:29 AM
It happens randomly, VS hangs for about 20 seconds with "Waiting for a required operation to complete" message after copy/paste in TypeScript source file.
I have VS 2013 RTM + TypeScript 0.9.5. No extensions (I have WebEssentials 2013 but it was disabled).
Posted by Frip28 on 12/26/2013 at 9:49 AM
I have a similar problem, at EACH time i do a copy paste in an ASPX file, it shows the "waiting for internal operation" window. I use VS2013, french version. It seeems that for some user VS crash, for my parte, i did'nt experienced a crach, but I have to wait at least 30 seconds before the copy text is copied.
Posted by Owen37 on 12/19/2013 at 2:18 PM
Some of our developers are experiencing this problem as well. Others are not. The one who has it the worst even installed the Update 1 RC which did NOT fix the problem.
Posted by Data Juggler on 12/10/2013 at 3:57 AM
To Microsoft: How can you close the issue? You haven't fixed it yet.

I didn't respond, because unlike you who has a cushy corporate job, I don't get paid unless I finish something.

Your instructions you asked for might as well have been in Greek; A dump what?

You have QA people to fix your software, I have work to do, I will BETA test a product you released as a full version when I have more time.

But thank you for my MSDN subscription, I am still the biggest Microsoft cheerleader, but please focus on desktop apps and Windows Forms, not Metro apps for tablets or phones as I use neither.
Posted by GearWorld on 12/10/2013 at 2:10 AM
Count me in. This is too much and this thing take a very long time. Please make a patch so the message tells us what is going on behind the scene in order for us to understand what operation and what is taking so long !

Visual Studio 2013 Premium
Very high end system
Very fast
Lots of memory
Nothing's wrong with the system
No adding whatsoever is running other then the default ones given when installing VS

Tested on Windows 8.1 and windows 7 both do the same thing so obviously there's something wrong in VS but whatever it is, The key here is to get at least a better message than this one in order to know what operaion is being processed and how long (PROGRESS BAR) it remains to wait !

Posted by Russ.Harding on 12/2/2013 at 5:58 AM
This is exactly what I have been getting. VS shows the waiting for operation dialog, then after a minute or two the dialog goes away and the status bar at the bottom blinks with the same message. I tried waiting ~10 minutes before killing with the task manager a couple times. My only "work around" has been to set the auto recovery very low so anything I am working on gets automatically saved so I don't loose too much when VS crashes.

I want my team to upgrade to 2013, but I can't justify it as long as it blatantly hangs 3-4 times a day.

I am using a Windows 7 x64 box, with a dedicated SSD for the OS/Software and a 2nd SSD for Development, 8 Processors and 12GB of RAM.
Posted by citykid dl on 11/22/2013 at 3:26 PM
have this issue several times a day. i takes about 1 or 2 minutes until ican continue working.

just downloaded the Feedback tool and will try to provide more Input.

bwt, this connect.microsoft.com page is hyper-ultra-slow. Response time for any interaction is in the minutes instead of milliseconds. since weeks at least.
Posted by Rogier Versluis on 11/17/2013 at 3:42 PM
This happens for me quite frequently when doing copy or cut. I can't launch the feedback tool because often it won't come back anymore. The dialog disappears after a few mins but in the status bar the message blinks.
Posted by Andomar_ on 11/12/2013 at 9:40 AM
If Visual Studio is hanging, how are you supposed to launch the feedback tool?
Posted by Thomas OR on 11/11/2013 at 9:43 AM
I used Visual Studio 2012 Ultimate with Team Foundation Server hosted at Microsoft. InstallShield InstallShield Limited Edition 2012 and Edition 2013 Limeted freezes. I have to use Task Manager to close to Visual Studio. The equipment of a new project in a solution is not possible. This happens under Windows 7 Ultimate and Windows 8 It has set a day taken to restore the computer. I will not use InstallShield in the future.

For more than 35 years, I am programming in Windows. First, assembler, then native C, C + + to C # today. Microsoft lives, among other things, that there is a lot of software. The developer community is appalled. All over the Internet you can find very bad comments about InstallShield LE. I hope Microsoft takes this idea of distance quickly.
Posted by Greg Oliver (DPE) on 11/11/2013 at 9:00 AM
This just happened to me for the first time. I'm adding a bunch of events to globals.asax.cs in an asp.net app. I was doing copy/paste operations - about 10. I'll try to repro.
Posted by Halvard Hagesæther on 11/4/2013 at 3:24 AM
I also noted that it used more and more memory. It was using 1.7 GB when I finally killed it. Could it be that some operation (copy & paste) goes into an infinite loop somehow?
Posted by Halvard Hagesæther on 11/4/2013 at 3:21 AM
I have Visual Studio 2013 Professional Edition Version 12.21005.1 REL and also get this error occasionally. I don't remember what caused it previously, but this last time it was selecting and copying text in a code file that caused it. Previously it has come back, but it does not look promising this time...
Posted by dickP on 11/2/2013 at 3:10 AM
I am getting this a lot too on VS2013 RTM. I can't recognize any pattern. Usually it is editor operations. Hang time varies from 30 seconds to many minutes. It usually comes back.
Posted by Microsoft on 10/30/2013 at 3:46 AM
Thank you for submitting feedback on Visual Studio and the .NET Framework. At this point, it has been more than 3 days since we initially requested additional information to reproduce your issue. Since we have not heard back from you we will close the issue. If you need further assistance on this or any other pre-release product issues in the future, please feel free to contact us and we will be happy to help.
Posted by Microsoft on 10/29/2013 at 5:08 AM
Hello again. We wanted to give you a quick reminder that to efficiently investigate and reproduce your issue, we need you submit the additional information we requested. We look forward to hearing from you with this information.
Posted by Microsoft on 10/27/2013 at 10:53 PM
Thanks for your feedback. In order to efficiently investigate and reproduce this issue, we are requesting additional information outlined below.

Could you please give us a dump file so that we can conduct further research?

Visual Studio now has an extension called Microsoft Visual Studio 2013 Feedback Tool, available on the VS gallery(<http://visualstudiogallery.msdn.microsoft.com/563d1003-f0ed-498f-8ef9-f8ee1aac39fe>)

The extension allows you to
1. upload files
2. collect trace and dump files
3. collect steps while you're repro'ing the issue
4. SQM logs about VS extensions installed
5. System details (in DxDiag output)

Please submit this information to us within 3 business days. We look forward to hearing from you with this information.

Microsoft Visual Studio Connect Support Team
Posted by Microsoft on 10/26/2013 at 10:53 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
Posted by Microsoft on 4/14/2014 at 3:15 PM
Please install VS 2013 Update 2 RC from http://www.microsoft.com/en-us/download/details.aspx?id=42307 in order to fix this issue.
File Name Submitted By Submitted On File Size  
procdump_devenv.zip (restricted) 2/3/2014 -
PerfView.part2.zip (restricted) 2/24/2014 -
PerfView.part1.zip (restricted) 2/24/2014 -
PerfView.zip (restricted) 2/24/2014 -
SolutionFingerprint.6096.xml (restricted) 4/11/2014 -
UploadSummary-140411143536.xml (restricted) 4/11/2014 -
SqmExtensionsLogs.zip (restricted) 4/11/2014 -
VsInfo.xml (restricted) 4/11/2014 -
ActivityLog.xml (restricted) 4/11/2014 -
DxDiagOutput.txt (restricted) 4/11/2014 -
SqmExtensionsLogs.zip (restricted) 4/29/2014 -
UploadSummary-140429164845.xml (restricted) 4/29/2014 -
DxDiagOutput.txt (restricted) 4/29/2014 -
VsInfo.xml (restricted) 4/29/2014 -
MiniDump5180.dmp (restricted) 4/29/2014 -
VsInfo.xml (restricted) 4/30/2014 -
UploadSummary-140430141535.xml (restricted) 4/30/2014 -
ETLTrace0430071424.etl.zip.txt (restricted) 4/30/2014 -
DxDiagOutput.txt (restricted) 4/30/2014 -
SqmExtensionsLogs.zip (restricted) 4/30/2014 -
SolutionFingerprint.1460.xml (restricted) 4/30/2014 -