Home Dashboard Directory Help
Search

[VS2013] Toolbar order reset on restart by Evgenii Golubev


Status: 

Active


1
0
Sign in
to vote
Type: Bug
ID: 808103
Opened: 11/8/2013 11:12:27 AM
Access Restriction: Public
0
Workaround(s)
view
0
User(s) can reproduce this bug

Description

I use an extension called Code Alignment. It adds its own toolbar to the list of standard ones.

Unfortunately, if I place this toolbar before (on the left of) standard Text Editor toolbar, upon restart it still (often, but not always) placed after Text Editor (i.e. ends up being the last one on the right).

I believe that for some reason standard toolbars are loaded and placed before those provided by extensions.
Details
Sign in to post a comment.
Posted by Evgenii Golubev on 11/24/2013 at 1:44 PM
Hi Carl,

I am using VS2013 RTM which I downloaded in October (I know there were some patches in the November ISO, I do not have those yet).

I am only using a single instance instance.

It usually goes like this: I change toolbars to the proper order then close the program. After reopening everything's fine. But if I close and then reopen VS again, the toolbar order resets.

I am attaching the files you requested. Hope it helps.

Best regards,
Evgenii
Posted by Microsoft on 11/18/2013 at 8:46 AM
Hi Evgenii

thank for providing us feedback. We're trying to reproduce the issue you are seeing in our lab but we're not seeing what you are seeing. Are you using multiple instances of Visual Studio? Can you send us screen captures before closing VS and after reopening it? It would be great if you can also export your settings and attach them to this issue.

Thanks
Carl Brochu | VS Team
Posted by Microsoft on 11/14/2013 at 1:31 AM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by Microsoft on 11/11/2013 at 11:40 PM
Hello again. We wanted to give you a quick reminder that to efficiently investigate and reproduce your issue, we need you submit the additional information we requested. We look forward to hearing from you with this information.
Posted by Microsoft on 11/11/2013 at 12:06 AM
Thanks for your feedback. According to the information you have provided, we couldn't encounter the same issue. In order to efficiently investigate and reproduce this issue, we are requesting additional information outlined below.

Could you please use the feedback tool to collect steps while you're reproducing the issue?

Visual Studio now has an extension called Microsoft Visual Studio 2013 Feedback Tool, available on the VS gallery(<http://visualstudiogallery.msdn.microsoft.com/563d1003-f0ed-498f-8ef9-f8ee1aac39fe>)

The extension allows you to
1. upload files
2. collect trace and dump files
3. collect steps while you're repro'ing the issue.
4. SQM logs about VS extensions installed
5. System details (in DxDiag output)

Please submit this information to us within 3 business days. We look forward to hearing from you with this information.
Posted by Microsoft on 11/8/2013 at 11:51 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
File Name Submitted By Submitted On File Size  
ReproSteps.zip (restricted) 11/12/2013 -
SolutionFingerprint.2948.xml (restricted) 11/12/2013 -
UploadSummary-131112192202.xml (restricted) 11/12/2013 -
VsInfo.xml (restricted) 11/12/2013 -
DxDiagOutput.txt (restricted) 11/12/2013 -
before.jpg 11/24/2013 151 KB
after.jpg 11/24/2013 139 KB
Exported-2013-11-24.vssettings.7z 11/24/2013 22 KB