Home Dashboard Directory Help

Startup checkbox in Add-in Manager of VS 2005 does not persist changes by Carlos Quintero MVP


Status: 

Closed
 as Fixed Help for as Fixed


12
0
Sign in
to vote
Type: Bug
ID: 238492
Opened: 11/16/2006 7:19:14 AM
Access Restriction: Public
0
Workaround(s)
view
6
User(s) can reproduce this bug

Description

This a bug already reported (#195760 and #105560) but is was closed in false because either the person reporting the problem failed to explain it correctly or the MS developer failed to understand and recognize the problem, so I will try again hopefully with more luck.

The problem is that when a Visual Studio 2005 add-in:

1) Is registered for all users (not just the current user)
2) Uses the registry (HKEY_LOCAL_MACHINE hive) to register it to Visual Studio 2005 instead of using XML registration with an .AddIn file

Then the Startup checkbox in the Add-in Manager is not persisted even if you are an administrator (a non-administrator user is expected NOT to be able to do that for an add-in registered for all users, but an administrator should be able to do that as he could in VS.NET 2003)
Details
Sign in to post a comment.
Posted by Aditya Pandey on 3/10/2008 at 2:47 AM
I have 2 add-ins VMWare and Visual Assist. Since we paid quite some money on Visual Assist and it is a crappy but useful add-in, I can't un-install. The only level I have is to launch while pressing Shift key.
Posted by Microsoft on 11/21/2006 at 10:18 AM
Thanks for reporting this issue! Unfortunately we won't be able to fix this in SP1 since it is about to ship and it is too late to get this fix in. We are going to reproduce this internally and if there are any workarounds we will add it to this bug report.

Thanks

The Visual Studio IDE Team
Sign in to post a workaround.