Home Dashboard Directory Help

Outlook 2007 causes Windows to configure Microsoft Visual Studio 2005 by CrazyBaldHead


Status: 

Closed
 as Fixed Help for as Fixed


2
1
Sign in
to vote
Type: Bug
ID: 290012
Opened: 7/31/2007 9:52:36 PM
Access Restriction: Public
3
Workaround(s)
view
4
User(s) can reproduce this bug

Description

When I open Outlook (Office 2007 Enterprise install), I receive a prompt to insert my Visual Studio 2005 DVD, and after doing so, I get the following message:

"Please wait while Windows configures Microsoft Visual Studio 2005 Professional Edition - ENU"

It takes an exceptionally long time for this process to complete. If I had to do it once, it wouldn't be that big of a deal. However, it appears as though I have to insert the VS 2005 DVD evertime after I reboot and start Outlook.
Details
Sign in to post a comment.
Posted by CrazyBaldHead on 8/14/2007 at 2:53 PM
Aaron,

Thanx for the workaround. I chose option #3, and it works like a charm and is a huge timesaver!

Thanx for all the help and for being super responsive; it is greatly appreciated!
Posted by Microsoft on 8/13/2007 at 6:31 PM
Hi,

It does not matter what you rename the registry values to in option #3. They just need to be different than "InprocServer32" in this case. The reason I suggest renaming instead of simply deleting is just in case you run into any issues and want to restore the registry values.

Renaming/deleting these values will not impact your ability to develop Outlook add-ins with Visual Studio 2005. In this case, it only stops Windows Installer from thinking that this COM object is advertised, which will prevent it from doing a health check for the VS MSI and notice that your USB hard drive is not currently connected. The features of both VS and Office will continue to function as expected.

I am going to resolve this issue as fixed because this type of repair will not happen in VS 2008. For VS 2005, one of these workarounds will have to be used however.

Thanks! Aaron
Posted by CrazyBaldHead on 8/11/2007 at 12:19 PM
Regarding option #3, what should the new name of the key be? And will this affect the operation of Outlook and/or Visual Studio, particularly developing outlook add-ins with S2005?
Posted by Microsoft on 8/10/2007 at 10:47 AM
Hi,

Thank you for the additional information from your application event log. There is a component in the VS product that has been incorrectly authored to try to use the drive with the largest amount of free space as a destination location, and that is causing this repair to be triggered when that drive is not available on the system.

There are some changes in the VS 2008 setup that will prevent this scenario from happening in the future, but for the VS 2005 product, you can use one of the following workarounds to stop this repair from being triggered each time you start Outlook:

1. Uninstall VS, then re-install it with the external hard drive disconnected

2. Leave the external hard drive connected when starting Outlook

3. Rename the following keys in your registry:

[HKEY_CLASSES_ROOT\CLSID\{AC0714F6-3D04-11D1-AE7D-00A0C90F26F4}\InprocServer32]
InprocServer32

[HKEY_CLASSES_ROOT\CLSID\{AC0714F7-3D04-11D1-AE7D-00A0C90F26F4}\InprocServer32]
InprocServer32

If you choose option 3, make sure to rename only the child value named InprocServer32, and do not rename the parent sub-key (which is also named InprocServer32).

If you are interested in more details about why this repair is happening, you can check out the following blog posts:

http://blogs.msdn.com/astebner/archive/2005/01/13/352649.aspx

http://blogs.msdn.com/astebner/archive/2004/08/24/219764.aspx

Thanks! Aaron
Posted by CrazyBaldHead on 8/9/2007 at 6:45 PM
Detection of product '{437AB8E0-FB69-4222-B280-A64F3DE22591}', feature 'VB_for_VS_7_Pro' failed during request for component '{DD68FEE8-C369-11D1-A173-00A0C90AB50F}'

Detection of product '{437AB8E0-FB69-4222-B280-A64F3DE22591}', feature 'Visual_Studio.NET_Professional', component '{9C843E45-C138-43EE-A224-7DB2F4AE317E}' failed. The resource 'J:\' does not exist.
-------------------------------------------------------------------
On my system, 'J:\' is a removable hard drive that is not always powered on. When I installed Office 2007 and VS 2005 they were both installed to their default directories. Is it possible that the install stored the component libraries on 'J:\' because at the time it had more space?

I powered on the drive and tried to open Outlook again, with the same result. However, I cleaned that drive since I installed both apps.

Posted by mphare1 on 8/9/2007 at 8:13 AM
I performed the steps you outlined above, here are my log entries from the event viewer:
8/9/2007    10:02:40 AM    MsiInstaller    Information    None    11729    FNC\mphare    R6911498-XP    Product: Microsoft Visual Studio 2005 Professional Edition - ENU -- Configuration failed.
8/9/2007    10:01:00 AM    MsiInstaller    Warning    None    1001    FNC\mphare    R6911498-XP    Detection of product '{437AB8E0-FB69-4222-B280-A64F3DE22591}', feature 'VB_for_VS_7_Pro' failed during request for component '{DD68FEE8-C369-11D1-A173-00A0C90AB50F}'
8/9/2007    10:01:00 AM    MsiInstaller    Warning    None    1004    FNC\mphare    R6911498-XP    Detection of product '{437AB8E0-FB69-4222-B280-A64F3DE22591}', feature 'Visual_Studio.NET_Professional', component '{9C843E45-C138-43EE-A224-7DB2F4AE317E}' failed. The resource 'E:\' does not exist.


It goes through these same errors 3 times each time I start up Outlook.

The only 'E:' drive I have is a removable USB disk. But it only holds data, nothing is installed on it.
Office2000 and VS2055 are both installed on the C: drive.

It appears that havin the E: drive present keeps the Outlook from starting up the VS2005 installer, but I'm not sure why this would be. It's not even the same USB drive I inserted into the system to create the E: drive, I just picked up the closed USB drive I could find. It was recently formatted so it's wiped clean anyway.

I can start VS2005 up without the E: drive, so I pretty confused as to why it needs to be there when I start Outlook.
Posted by Microsoft on 8/8/2007 at 3:44 PM
Hi,

I'm sorry that you're running into this issue. Can you please reproduce the repair one more time and cancel when the disk prompt appears. Then can you go to the application event log on your system and find the most recent warnings from the MsiInstaller source and paste the text of them here (there should be 2 of them). That will help us narrow down why this repair is happening.

To get to the application event log, you can click on the Start menu, choose Run, type eventvwr and click OK. Then you can click on the Application item in the tree view with the names of logs on your system.

Thanks!

Aaron Stebner
Program Manager, Microsoft Corporation
http://blogs.msdn.com/astebner/
Posted by Microsoft on 7/31/2007 at 10:27 PM
Thank you for your feedback. We are currently investigating. If this issue is urgent, please call support directly (see http://support.microsoft.com). Thank you, Visual Studio Product Team.
Sign in to post a workaround.
Posted by Jan Borup Coyle on 2/13/2010 at 4:07 PM
I now have a brand new Windows 7 x64 with Office 2007, and have installed Visual Studio 2010 Beta 1, Beta 2 and now RC.

It's stills starts the installation of VS when i starts my Outlook 2007, in every VS 2010 versions.

If I uninstall VS 2010, Outlook starts normal.
Posted by Raeed1 on 6/8/2008 at 12:54 PM
When I run the installed VB6 the message box appear to include " Please Wait While Windows Configures Microsoft Visual Studio 2008 Professional Edition-ENU" ,I am already installed the Visual studio 2008..I visited the web site of Microsoft to obtain the solution but nothing in the mean time
Posted by Raeed1 on 6/8/2008 at 12:54 PM
When I run the installed VB6 the message box appear to include " Please Wait While Windows Configures Microsoft Visual Studio 2008 Professional Edition-ENU" ,I am already installed the Visual studio 2008