Home Dashboard Directory Help

SP1 Vs2008 Installation Error by tinchoss


Status: 

Closed
 as Not Reproducible Help for as Not Reproducible


10
0
Sign in
to vote
Type: Bug
ID: 362464
Opened: 8/19/2008 7:03:55 AM
Access Restriction: Public
6
Workaround(s)
view
17
User(s) can reproduce this bug

Description

Throw an error during installation on a pc running windows Vista with Updates and Service Pack, also trhow the same error on a pc running Vista, no Service Pack and no updates.

Error Log :
.....
[8/19/2008, 8:19:47] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\horacio.INVICO\Downloads\Visual Studio 2008 SP1 - ENG\vs90sp1\VC_IA64Runtime.exe - Exe installer's log file/hint (%temp%\dd_VC_IA64Runtime*.txt|%temp%\..\dd_VC_IA64Runtime*.txt) does not exist or is invalid.....
......
[8/19/2008, 8:19:47] (IronSpigot::LogUtils::LogFinalResult) Final Result: Installation failed with error code: (0x80070654), No se puede abrir este paquete de instalación. Póngase en contacto con el fabricante de la aplicación para comprobar que es un paquete del Instalador de Windows válido.
Details
Sign in to post a comment.
Posted by Kenneth Xu from BN on 11/23/2011 at 12:58 PM
I had exactly same error message as the original reporter, tinchoss. Uninstalling Remote Debugger for VS2008 fixed the issue.
Posted by ihatems2 on 7/15/2011 at 1:49 PM
I'm having this problem too. Workarounds aren't working for me or are irrelevant.
This is typical of Microsoft to just ignore the issue and let us all suffer. I can't wait to get back working on Linux.
Posted by Paul Reitmeyer on 9/20/2010 at 8:35 AM
I managed to get this working also only by Removing Office 2007 (I have 2010 installed.. but still had Word 2007). See Workarounds tab for additional details.... and lay off the Microsoft bashing everyone else.. they do the best they can.
Posted by Chris Sutton on 2/10/2010 at 4:12 PM
I'm getting the same error on an XP machine when try to install VS 2008 SP1.
Posted by Collin Sauve on 11/20/2009 at 8:44 AM
I get this error too. Looks like Microsoft doesn't really care.
Posted by Thandermax on 11/17/2009 at 12:36 AM
Continued ...


Created new MultipleMspPerformer for Patches item
[11/17/2009, 13:32:51] Entering Function: IronSpigot::BaseMspInstaller::PerformAction...
[11/17/2009, 13:32:51] Entering Function: IronSpigot::MspInstallerT > > >::PerformMsiOperation...
[11/17/2009, 13:32:51] Action: Install patch (E:\vs90sp1\VS90sp1-KB945140-X64-ENU.msp) to Microsoft Visual Studio 2008 Remote Debugger - ENU...
[11/17/2009, 13:32:51] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) Calling MspApplyMultiplePatches to apply patch {E:\vs90sp1\VS90sp1-KB945140-X64-ENU.msp} to product {64D5BBC6-5270-3711-AA39-31C1087AF4E6}.
[11/17/2009, 13:32:51] (IronSpigot::BaseMspInstaller::SetMsiLoggingParameters) Successfully called MsiEnableLog with log file set to C:\Users\Admin\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio 2008 Remote Debugger - ENU-MSP0.txt
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: INSTALL. ]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: FindRelatedProducts. Searching for related applications]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: CA_SystemFolder_amd64.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: CA_WindowsFolder_amd64.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: LaunchConditions. Evaluating launch conditions]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: CA_SetRTM_ProductName_amd64_enu. ]
[11/17/2009, 13:32:52] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:52: AppSearch. Searching for installed applications]

...
...

Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:33:53: StopServices. Stopping services]
[11/17/2009, 13:33:53] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:33:53: RemoveODBC. Removing ODBC components]
[11/17/2009, 13:33:53] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:33:53: RemoveRegistryValues. Removing system registry values]
[11/17/2009, 13:33:53] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:33:53: CreateFolders. Creating folders]
[11/17/2009, 13:33:53] (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning IDOK. INSTALLMESSAGE_ERROR [Error 1303.The installer has insufficient privileges to access this directory: E:\Program Files. The installation cannot continue. Log on as administrator or contact your system administrator.]
[11/17/2009, 13:33:53] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:33:53: Rollback. Rolling back action:]
[11/17/2009, 13:33:54] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) Patch (E:\vs90sp1\VS90sp1-KB945140-X64-ENU.msp) install failed on product (Microsoft Visual Studio 2008 Remote Debugger - ENU). Msi Log: Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio 2008 Remote Debugger - ENU-MSP0.txt
[11/17/2009, 13:33:54] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) MsiApplyMultiplePatches returned 0x643
[11/17/2009, 13:33:54] Action complete. Log File: C:\Users\Admin\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio 2008 Remote Debugger - ENU-MSP0.txt
[11/17/2009, 13:33:54] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) exiting function/method
[11/17/2009, 13:33:54] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) failed and stopped (no rollback)
[11/17/2009, 13:33:54] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x643
[11/17/2009, 13:33:54] (IronSpigot::BaseMspInstaller::PerformAction) exiting function/method
[11/17/2009, 13:33:54] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x643
[11/17/2009, 13:33:54] (IronSpigot::LogUtils::LogFinalResult) Final Result: Installation failed with error code: (0x80070643), Fatal error during installation.
[11/17/2009, 13:33:54] Action complete
Posted by Thandermax on 11/17/2009 at 12:31 AM
Actual error log for MICROSOFT TO CONSIDER :


[11/17/2009, 13:16:47]
Products to be updated are:

1. Visual C++ 2008 SP1 - x86 Runtime
2. Visual C++ 2008 SP1 - x64 Runtime
3. Visual C++ 2008 SP1 - IA64 Runtime
4. Microsoft Visual Studio Team System 2008 Development Edition - ENU
5. Microsoft Visual Studio 2008 Remote Debugger - ENU
6. Visual Studio .NET Prerequisites - English
7. Microsoft Visual Studio 2008 Performance Collection Tools - ENU
8. Visual Studio Tools for the Office system 3.0 Runtime
9. Microsoft Windows SDK for Visual Studio 2008 Tools
10. Microsoft Windows SDK for Visual Studio 2008 Win32 Tools
11. Microsoft Windows SDK for Visual Studio 2008 .NET Framework Tools
12. SQL Server System CLR Types
13. Microsoft SQL Server Management Objects
14. SQL Publishing Wizard 1.3
15. Microsoft SQL Server Compact 3.5 SP1 (ENU)
16. Microsoft SQL Server Compact 3.5 SP1 Design Tools (ENU)

Created new ExePerformer for Exe item
[11/17/2009, 13:17:0] Action: Performing Action on Exe at E:\vs90sp1\VC_IA64Runtime.exe...
[11/17/2009, 13:17:0] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) In PreCreateProcess
[11/17/2009, 13:17:0] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) m_pSetupWatcher->Connect succeeded
[11/17/2009, 13:17:0] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = VC_IA64Runtime.exe /q /progress CartmanSetupExeWatcher916958001
[11/17/2009, 13:17:0] (IronSpigot::CartmanExeInstallerBase::PostCreateProcess) PostCreateProcess succeeded
[11/17/2009, 13:17:4] (IronSpigot::ExeInstallerBase::PerformAction) E:\vs90sp1\VC_IA64Runtime.exe - Exe installer's log file/hint (%temp%\dd_VC_IA64Runtime*.txt|%temp%\..\dd_VC_IA64Runtime*.txt) does not exist or is invalid.
[11/17/2009, 13:17:4] (IronSpigot::ExeInstallerBase::PerformAction) Exe (E:\vs90sp1\VC_IA64Runtime.exe) succeeded.
[11/17/2009, 13:17:4] Action complete
[11/17/2009, 13:17:4] Exists: evaluating...
[11/17/2009, 13:17:4] (IronSpigot::RegKeyT<class ATL::CRegKey>::Evaluate) RegKey: HKLM\SOFTWARE\Microsoft\VisualStudio\9.0 exists.
[11/17/2009, 13:17:4] Exists evaluated to true


Created new MultipleMspPerformer for Patches item
[11/17/2009, 13:17:4] Entering Function: IronSpigot::BaseMspInstaller::PerformAction...
[11/17/2009, 13:17:10] Entering Function: IronSpigot::MspInstallerT > > >::PerformMsiOperation...
[11/17/2009, 13:17:10] Action: Install patch (E:\vs90sp1\VS90sp1-KB945140-X86-ENU.msp;E:\vs90sp1\VC90sp1-KB947888-x86-enu.msp) to Microsoft Visual Studio Team System 2008 Development Edition - ENU...
[11/17/2009, 13:17:10] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) Calling MspApplyMultiplePatches to apply patch {E:\vs90sp1\VS90sp1-KB945140-X86-ENU.msp;E:\vs90sp1\VC90sp1-KB947888-x86-enu.msp} to product {6721AC10-3743-38F1-B178-C0EC6C9A4108}.
[11/17/2009, 13:17:10] (IronSpigot::BaseMspInstaller::SetMsiLoggingParameters) Successfully called MsiEnableLog with log file set to C:\Users\Admin\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio Team System 2008 Development Edition - ENU-MSP0.txt
[11/17/2009, 13:17:24] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:17:24: INSTALL. ]
[11/17/2009, 13:17:24] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:17:24: FindRelatedProducts. Searching for related applications]
[11/17/2009, 13:17:24] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:17:24: CA_SystemFolder_x86.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[11/17/2009, 13:17:24] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:17:24: CA_WindowsFolder_x86.3643236F_FC70_11D3_A536_0090278A1BB8. ]

....
....
Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:31:51: InstallFinalize. ]
[11/17/2009, 13:31:53] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:31:53: RollbackCleanup. Removing backup files]
[11/17/2009, 13:32:47] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:47: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:48] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:48: ConfigureNativeImage. Installing native images ]
[11/17/2009, 13:32:49] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 13:32:49: CA_RemoveTempHxDs.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[11/17/2009, 13:32:50] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) Patch (E:\vs90sp1\VS90sp1-KB945140-X86-ENU.msp;E:\vs90sp1\VC90sp1-KB947888-x86-enu.msp) install succeeded on product (Microsoft Visual Studio Team System 2008 Development Edition - ENU). Msi Log: Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio Team System 2008 Development Edition - ENU-MSP0.txt
[11/17/2009, 13:32:50] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) MsiApplyMultiplePatches returned 0x0: no error
[11/17/2009, 13:32:50] Action complete. Log File: C:\Users\Admin\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20091117_131640413-Microsoft Visual Studio Team System 2008 Development Edition - ENU-MSP0.txt
[11/17/2009, 13:32:50] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) exiting function/method
[11/17/2009, 13:32:50] (IronSpigot::MspInstallerT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > >::PerformMsiOperation) succeeded
[11/17/2009, 13:32:50] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x0

exiting function/method
[11/17/2009, 13:32:50] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x0
Posted by Thandermax on 11/17/2009 at 12:18 AM
Please refer to this post :

http://www.pieterdebruin.net/2009/02/01/VisualStudio2008ServicePack1InstallationErrorOnX64.aspx

It describes the same problem..

It says to "uninstall the Remote Debugger from Add/Remove Programs and then install Service Pack 1"
Posted by Lolita Broka on 2/19/2009 at 3:09 PM
I have the same issue. Failed to install VS 2008 SP1. OS: Windows 7 Ultimate.

I've tried both methods to install:
1) download and run VS90sp1-KB945140-CHT.exe directly
2) download the ISO file and run it through virtual CD software

Result:

K:\vs90sp1\VC_IA64Runtime.exe - Exe installer's log file/hint (%temp%\dd_VC_IA64Runtime*.txt|%temp%\..\dd_VC_IA64Runtime*.txt) does not exist or is invalid
Exe (K:\vs90sp1\VC_IA64Runtime.exe) succeeded.
Patch (K:\vs90sp1\VS90sp1-KB945140-X86-ENU.msp;K:\vs90sp1\VC90sp1-KB947888-x86-enu.msp;K:\vs90sp1\VC90sp1-KB948484-x86_x64-enu.msp) install failed on product (Microsoft Visual Studio 2008 Professional Edition - ENU).

---------------------------------------------

Posted by Microsoft on 1/23/2009 at 3:48 PM
We were unable to reproduce this internally but would like the chance to resolve this more completely. If you can repro, please send us logs via Heath's recommendations (http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx) and we'll continue our investigations.
Posted by JAMES_DEV on 11/13/2008 at 1:27 AM
As usual, MS pretends there's no problem so we waste hours or days.
We all accept software has bugs in it; why can't MS actually help us with these problems.

I tried:
- installing a later version of windows installer
- uninstalling third party items from visual studio toolbox
- retry installing sp1

However, it just seemed to work after a few retries with no logic to it...

MS should actually tell us what the problem is.
OUR customers wouldn't accept Customer Support making unreasonable requests for infomation deliberately so a call can be closed.
Posted by chipar on 10/29/2008 at 3:54 PM
Workaround# 1 didn't work for me.
Posted by Jonyboy on 10/8/2008 at 11:04 AM
Eventually I managed to install. See "Workaround"
Posted by Jonyboy on 8/29/2008 at 7:25 AM
Anyone worked this out?
Posted by Microsoft on 8/27/2008 at 11:32 PM
Hi, given that we have not heard back from you in 7 days. We will go ahead and close this Connect Issue. If you get a chance to review and provide the information requested earlier, you can go ahead and reactivate this issue.
Posted by Microsoft on 8/20/2008 at 1:43 AM
Thanks for reporting the issue.
In order to fix the issue, we must first reproduce the issue in our labs. We are unable to reproduce the issue with the steps you provided.

It may help if you provide us with:
a setup log file

You can get the log files with the following steps:
1) Download collect.exe from the link below. http://blogs.msdn.com/heaths/attachment/8483493.ashx
2) You may choose to save the tool for later use, or to run directly.
3) The utility creates a compressed cabinet of all the VS and .NET logs to %TEMP%\vslogs.cab.

You can get more details about how to get the log files here:
http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx


Thanks again for your efforts and we look forward to hearing from you.
Visual Studio Product Team
Sign in to post a workaround.
Posted by PoorFunny on 11/14/2011 at 3:58 PM
For me it was "Lookout" (a very good Outlook plug for searching) I hacked in with Outlook 2007 causing the issue. Undo the two renames fixed the issue.

C:\Windows\assembly\GAC>ren Microsoft.Office.Interop.Outlook Microsoft.Office.Interop.Outlook.LOOKOUT
C:\Windows\assembly\GAC>ren Microsoft.Office.Interop.Outlook.OLD Microsoft.Office.Interop.Outlook
C:\Windows\assembly\GAC>ren Policy.11.0.Microsoft.Office.Interop.Outlook.OLD Policy.11.0.Microsoft.Office.Interop.Outlook

Log entries:

Entering Function: IronSpigot::BaseMspInstaller::PerformAction
Entering Function: IronSpigot::MspInstallerT > > > >::PerformMsiOperation
Action: Install patch (C:\Users\peifengn\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\WebDesignerCore_KB950278.msp) to Microsoft Office Enterprise 2007
Returning IDOK. INSTALLMESSAGE_ERROR [Error 2902.An internal error has occurred. (ixfAssemblyCopy ) Contact Microsoft Product Support Services (PSS) for assistance. For information about how to contact PSS, seePSS10R.CHM.]
Patch (C:\Users\peifengn\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\WebDesignerCore_KB950278.msp) install failed on product (Microsoft Office Enterprise 2007). Msi Log: Microsoft Visual Studio 2008 SP1_20111114_153833978-Microsoft Office Enterprise 2007-MSP0.txt
MsiApplyMultiplePatches returned 0x643
Action complete. Log File: C:\Users\peifengn\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1_20111114_153833978-Microsoft Office Enterprise 2007-MSP0.txt
failed and stopped (no rollback)
PerformMsiOperation returned 0x643
Posted by Meaning Of Lights on 2/15/2010 at 9:02 PM
Microsoft PSS to repro the problem..

1. Download the ISO: http://www.microsoft.com/downloads/details.aspx?familyid=27673c47-b3b5-4c67-bd99-84e525b5ce61

Most people find it from here: http://blog.tiensivu.com/aaron/archives/1687-Speaking-of-Visual-Studio-2008-SP1-here-are-the-download-links-with-.NET-3.5-SP1.html

2. Extract it with WinRar

3. Install VS2008 SP1 from your local HDD

4. You'll see, VC_x64Runtime is corrupt as per: http://social.msdn.microsoft.com/Forums/en/vs2008sp1beta/thread/720ad3f5-2593-45e0-8d72-ea09b42fe977

When I deleted VC_x64Runtime then the SPinstaller failed on VC_IA64Runtime.

I successfully installed SP1 for VS2008 using the web setup: VS90sp1-KB945140-ENU.exe

HTH

Jeremy (X PSS Dev Eng)
Posted by itatang on 12/3/2009 at 6:44 PM
The following error is logged during the installation:

CA_SetPFF_For_SDKDotNetFX35_x86_enu.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[12/4/2009, 9:22:43] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 9:22:43: SetODBCFolders. Initializing ODBC directories]
[12/4/2009, 9:22:43] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 9:22:43: InstallValidate. Validating install]
[12/4/2009, 9:34:5] (IronSpigot::FilesInUseMessageHandler::ProcessMessage) , The following applications should be closed before continuing the install:: , Machine Debug Manager
[12/4/2009, 9:40:18] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 9:40:18: InstallInitialize. ]
[12/4/2009, 9:40:18] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 9:40:18: CA_ExportTempHxDs.3643236F_FC70_11D3_A536_0090278A1BB8. ]
[12/4/2009, 9:40:18] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 9:40:18:

I stopped the mdm.exe using the task manager and retry to continue the installation.
Posted by Ritter Insurance Marketing on 7/1/2009 at 5:22 AM
I uninstalled Office 2007 and was able to complete the upgrade.

No other methods worked for me.

I reinstalled Office 2007 afterwards and seem to be fine now.
Posted by Jonyboy on 10/8/2008 at 11:07 AM
First workaround listed didn't work for me. After searching everywhere and trying just about anything, Uninstalling all VS2008 related application including VS2008, then reinstalling VS2008 and immediately SP1 - was the only thing that did the trick.
Posted by BW-Updated on 8/20/2008 at 11:26 AM
On two computers I had this same failure. On both I rebooted after the failure and reran spinstaller and the install worked. So steps are
(1) Run install and let it fail
(2) Reboot
(3) ReRun install and it shold succeed