Label won't trigger input focus if I use anything other than text inside a label - by RyanSeddon

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


ID 542479 Comments
Status Closed Workarounds
Type Bug Repros 1
Opened 3/16/2010 10:29:04 PM
Access Restriction Public

Description

If I have a label with a for attribute to corresponding input and I have an image instead of text inside the label the input will never get focus. 

If I place some text along with an image inside a label clicking the text will bring focus to the input but clicking the image still won't trigger it.

If I remove the image and just have text inside the label the behaviour works as expected.

Lastly if I insert a span and a non-breaking space html entity give it a width and height and apply a background image the input will get focus on cliking the label.

This works in all other browsers.
Sign in to post a comment.
Posted by Microsoft on 3/7/2011 at 5:30 PM
Thank you for your feedback.

This issue was resolved in Internet Explorer 9 RC and the Platform Preview Build released on 2/10/2011. Please verify the change and file a new feedback (or reactivate the existing one) if the problem persists.

Best regards,

The Internet Explorer Team
Posted by Taciturne on 10/25/2010 at 7:14 AM
Will most likely not be fixed
https://connect.microsoft.com/IE/feedback/details/348575/ie-v8-0-image-inside-a-label-with-for-attribute-not-reacting-as-expected
Posted by Microsoft on 3/19/2010 at 4:25 PM
Thank you for your feedback. We were able to reproduce the issue and are investigating this.

Best regards,

The IE Team