SVG display issues with IE 11 - by Rambabu Yadlapalli

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


ID 794664 Comments
Status Closed Workarounds
Type Bug Repros 5
Opened 7/21/2013 9:31:38 PM
Access Restriction Public

Description

In IE 11 some of the SVG contents are not visible. While those are appearing perfectly on IE 10
Sign in to post a comment.
Posted by jedmao on 10/24/2014 at 6:18 PM
I figured out how to fix the display in IE 11, but this should NOT be required. All I had to do was change the img tag to a div tag, set the background-image, width, height... and the most important part was background-size: 100%; See my jsfiddle: http://jsfiddle.net/f0yw1dma/12/
Posted by jedmao on 10/24/2014 at 6:11 PM
Please see http://jsfiddle.net/f0yw1dma/4/ to reproduce the issue. As you can see, the SVG is being trimmed instead of being resized.
Posted by Excel services Cache on 5/20/2014 at 5:10 AM
I am noticing this issue (related to SVG rendering) as well. Unable to view arrowhead for a dashed-line in IE11 (this works perfectly alright with IE9 & IE10). My OS is Win 8.1 and my IE version is 11.0.9600.16661.
Posted by Chooch84 on 2/14/2014 at 6:04 AM
Cannot see SVG images. on build 11.0.9600.16518, any progress news?
Posted by George Crawford on 12/19/2013 at 7:23 AM
Hi,

I'm new to cutting-edge IE development. I'm also seeing this bug in IE 11.0.9600.16476. Can you tell me what is meant by the "IE11 GA" in this context, and how I can install it?

Many thanks
Posted by LucidDavid200 on 11/2/2013 at 11:42 AM
The web tool at www.shotklip.com uses SVG for image clipping service, only the very simplest shapes (circle, rect) display, all more complex shapes just appear as a white box in both IE 10 and IE 11.
Posted by Microsoft on 10/11/2013 at 11:59 AM
Rambabu,

This issue has been resolved in the latest internal builds of IE11. These updates will be made available for install in the coming weeks and should resolve the issue. If you install the IE11 GA and you are still experiencing this behavior, please feel free to reopen this feedback or you can open a new feedback with the latest details of the problem.

Best regards,

The Internet Explorer Team
Posted by CristianCson on 8/20/2013 at 8:44 AM
I thought that I could reproduce this svg issue, but it was that I had enabled Compatibility mode in IE11 on local sites.

I get the same behavior if I use F12 and change to Compatibility mode then no svg images are shown both in IE11 and IE10.

Without the setting everything works fine.
Posted by Microsoft on 8/12/2013 at 12:11 PM
Thank you for your feedback.

We are currently unable to reproduce this issue as described.


We value your feedback. If you have additional information that can help us recreate this issue — such as a specific url, more detailed steps, test results from different machines, or additional conditions — please reactivate the bug or submit a new bug with more details on how to reproduce the issue. You can also read the guidelines at https://connect.microsoft.com/IE/content/content.aspx?ContentID=16254 regarding filing a good bug report.

Best regards,

The Internet Explorer Team
Posted by Microsoft on 7/26/2013 at 7:18 AM
Please disregard the last message, we are still investigating this issue.

Best regards,

The Internet Explorer Team
Posted by Microsoft on 7/26/2013 at 7:17 AM
Thank you for your feedback.

We are currently unable to reproduce this issue as described.

We value your feedback. If you have additional information that can help us recreate this issue — such as a specific url, more detailed steps, test results from different machines, or additional conditions — please reactivate the bug or submit a new bug with more details on how to reproduce the issue. You can also read the guidelines at https://connect.microsoft.com/IE/content/content.aspx?ContentID=16254 regarding filing a good bug report.

Best regards,

The Internet Explorer Team
Posted by Microsoft on 7/24/2013 at 7:20 AM
Thank you for your feedback. We will be investigating this issue further.

Best regards,

The Internet Explorer Team