SSMS 2016 causes error "18456 Login failed" when no access to first database - by Manuel Burggraf

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


4
0
Sign in
to vote
ID 3135032 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 5/31/2017 4:50:11 AM
Access Restriction Public

Description

SSMS 2016 causes error log entry '18456 - Login failed - Reason: Failed to open the explicitly specified database' when login is not allowed to enter first database in alphabetical order
Sign in to post a comment.
Posted by Microsoft on 11/10/2017 at 1:48 AM
Hi Manuel,
Thanks for letting us know. Yes, we don't usually go back to old SSMS (we recommend to always move forward and get the latest, which has all the fixes and new features).

I'm going to close this connect item as "Fixed", since you confirmed it went away in SSMS 17.3.

Regards,
-Matteo
Posted by Manuel Burggraf on 11/10/2017 at 1:37 AM
Hi,

just let you know in SSMS v17.3 (14.0.17199) the mentioned error is fixed.
Still have the error in SSMS 2016 (13.0.16106.4) but that's okay.

Cheers,
Manuel
Posted by Manuel Burggraf on 8/4/2017 at 2:07 AM
Hey Matteo,

the fule upload to connect is working again - after a long long time.
I recorded a short video of the few steps I did to reproduce the error and attached it to this feedback.

Three windows are shown:
- upper left: SQL Server Log File Viewer
- right: SSMS started as AD-user with sysadmin permission on the SQL Server
- lower left: SSMS started as AD-user without any permission on the SQL Server

The steps:
-- as sysadmin
- check - errorlog is empty
- create new database aa
- create new login without any additional permission (default DB is master)
-- as non-sysadmin
- log in to SQL Server
- expand databases in Object Explorer - wait
-- as sysadmin
- check errorlog - error is shown: Login failed for user ... Reason: Failed to open the explicitly specified database 'aa'

SQL Server Version: 13.0.4435.0
SQL Server Language: english
SQL Server Windows Language: english
SSMS Version: 13.0.16106.4
SSMS Language: english
SSMS Windows Language: german

In addition I scripted the database and the login and also attached it to the feedback.

With best regards,
Manuel
Posted by Manuel Burggraf on 6/7/2017 at 8:41 AM
Hi Matteo,

thanks for your response.
Since days I am trying to upload files to this feedback - doesn't work. Have informed administrators - hopefully the correct ones...
I have recorded a short video reproducing the error and have a file with the scripts.
I keep on trying uploading the files...

Manuel
Posted by Microsoft on 6/2/2017 at 6:19 PM
Hi Manuel,
I've tried to repro the issue you reported on my machine, but I did not have much luck. Could you kindly provide more specific repro steps, so I can do my investigation? Ideally, if you could script the databases and the users, it would be terrific.

Thanks,
-Matteo