Index was outside the bounds of the array. (Microsoft.SqlServer.Smo) while connecting from SSMS 2005/2008 - by Vishal Gajjar

Status : 

  Won't Fix<br /><br />
		Due to several factors the product team decided to focus its efforts on other items.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


4
3
Sign in
to vote
ID 666386 Comments
Status Closed Workarounds
Type Bug Repros 2
Opened 5/3/2011 5:46:01 AM
Access Restriction Public

Description

When you try to connect to a "Denali" instance from SSMS 2005 or SSMS 2008 you will receive an error message:
"Index was outside the bounds of the array. (Microsoft.SqlServer.Smo)"
Sign in to post a comment.
Posted by Microsoft on 6/14/2011 at 2:05 PM
Hi Vishal,

This is not a supported scenario. We will not be fixing this.

Thanks,
Nikhil
SQL Server Program Manager
Posted by AaronBertrand on 5/3/2011 at 9:35 AM
Sorry, my comment should read, "...and Microsoft is ***NOT*** going to go back and retrofit 2005 / 2008 SSMS..."
Posted by AaronBertrand on 5/3/2011 at 9:01 AM
Old versions of SSMS are not going to magically become forward compatible, and Microsoft is going to go back and retrofit 2005 / 2008 SSMS so they can connect to Denali. On your workstations you should always be using client tools that match the *highest* version of all of the instances you're connecting to, then you won't be missing out on any functionality or getting error messages.

See this item for Microsoft's official stance about forward compatibility (not going to fix) and backward compatibility (Denali SSMS will be able to manage 2000, 2005, 2008, 2008 R2):

http://connect.microsoft.com/SQLServer/feedback/details/622441