Cannot specify HTTPS in an Analysis Services Report Action - by Darren Gosbell

Status : 

 


14
0
Sign in
to vote
ID 692837 Comments
Status Closed Workarounds
Type Bug Repros 6
Opened 10/3/2011 1:45:36 PM
Access Restriction Public

Description

There should be a place in the report action properties where you can specify HTTPS at the moment Analysis Services always creates the report server url using HTTP
Sign in to post a comment.
Posted by GregGalloway on 3/31/2017 at 7:59 PM
The unfortunate side effect of this change is that when you specify a Report Action in a Multidimensional model and set "Server name" to just servername then the action won't show up in Excel in SSAS 2016 because the URL doesn't start with http or https. So an action which was working in SSAS 2014 suddenly stops working in SSAS 2016 until you change the "Server name" property of the report action to include http:// or https://

The above also applies to SSAS Tabular models and the BIDS Helper Tabular Actions Editor feature which works on 1103 compatibility level models.
Posted by Microsoft on 4/20/2016 at 6:38 PM
In SQL Server 2016, you will be able to prefix the report server name with http:// or https:// and address this problem.

Thanks for reporting this issue!

- The Analysis Services team
Posted by Roy JC on 1/11/2013 at 12:37 PM
So far, no fix yet.
Posted by Microsoft on 10/4/2011 at 6:21 PM
Thank you for reporting this issue. We will this for the next release based on the amount of feedback we receive.

Thank you
Claudio Mauad
Analysis Services Team