RC0 rule - requires VS2010 SP1 when CTP3 installed VS2010 - by Rei

Status : 

  By Design<br /><br />
		The product team believes this item works according to its intended design.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


7
1
Sign in
to vote
ID 709599 Comments
Status Closed Workarounds
Type Bug Repros 3
Opened 11/29/2011 10:40:10 AM
Access Restriction Public

Description

While running the upgrade from CTP3 to RC0 the upgrade rules errors saying:

---------------------------
Rule Check Result
---------------------------
Rule "Prior Visual Studio 2010 instances requiring update." failed.

This computer has an installation of Visual Studio 2010 that requires a Service Pack 1 update that is needed for a successful installation of SQL Server based on your feature selection. To continue, install the required Visual Studio 2010 Service Pack 1 from SQL Server media or from http://go.microsoft.com/fwlink/?LinkID=220649.
---------------------------
OK   
---------------------------

But the VS2010 was not manually installed, but installed by CTP3. Being that the case, RC0 should upgrade all the components needed.

Also, it would be a lot easier to have these checks as a separate tool or at the begining so that one does not reach the second to last step on the setup to find out it has to apply SP1 and start all over the 2012 RC0 upgrade.
Sign in to post a comment.
Posted by Microsoft on 11/29/2011 at 12:07 PM
Hello, thanks for reporting this. Your suggestion about performing the check earlier and automatically installing necessary udpates is a good one. We will take this under consideration for a future release.

thanks,
Robert