Home Dashboard Directory Help
Search

free masm 8.0 download does not work with visual studio express 2008 by idadesub


Status: 

Closed
 as Fixed Help for as Fixed


2
0
Sign in
to vote
Type: Suggestion
ID: 312421
Opened: 11/26/2007 8:11:48 PM
Access Restriction: Public
1
Workaround(s)
view

Description

I have been using visual studio express 2005 and the free masm download (MASMSetup.exe) from:

http://www.microsoft.com/downloads/details.aspx?familyid=7A1C9DA0-0510-44A2-B042-7EF370530C64&displaylang=en

to work with native ocaml code generation, which uses masm to compile it's assembly code. Unfortunately, since upgrading to 2008 (and removing 2005), masm refuses to reinstall because it needs 2005. Would it be possible to update the masm installer to work with 2008?

It would be much simpler if it were just installed along with the rest of 2008 express, but I understand that it was purposely left out.
Details
Sign in to post a comment.
Posted by Microsoft on 2/28/2008 at 2:31 PM
I thought I would post an update that affects this.

We've had a number of requests to have Visual C++ Express include the Microsoft Macro Assembler (MASM or vc\bin\ml.exe). Based on this feedback we will be adding MASM to the upcoming release of Visual C++ Express 2008 SP1. This will eliminate the need for a separate download.

Thanks for the feedback on this.
Visual Studio Product (and MASM) Team
Posted by gel on 12/1/2007 at 3:18 PM
[quote]You can install VS 2005 side by side with VS 2008 as a work around for this for now.[/quote]

That's ridiculous. The Express Edition is directed towards hobbyists and students. I would say hobbyists and students are pretty big users of MASM. At least make it available as a download for the Express Edition like it was for VC++ 2005.

Posted by Microsoft on 11/27/2007 at 3:16 PM
You can install VS 2005 side by side with VS 2008 as a work around for this for now. I'll investigate the issue further to determine the problem behind that. Thanks for your report.

Rick Benge
Sign in to post a workaround.
Posted by idadesub on 11/26/2007 at 8:12 PM
Use visual studio express 2005.