Home Dashboard Directory Help
Search

VS Crash with control created dinamically in Usercontrol, using TablelayoutPanel ... in design mode by David Daniel Arroyo Zari. -Ddaz-


Status: 

Closed
 as Fixed Help for as Fixed


5
0
Sign in
to vote
Type: Bug
ID: 355116
Opened: 7/6/2008 8:04:57 AM
Access Restriction: Public
0
Workaround(s)
view
6
User(s) can reproduce this bug

Description

Visual Studio Crashm with controls created dinamically in a Usercontrol, using TableLayoutPanel.... from Winfows form in desgin mode.....

dinamic control.. in design mode ( from windows form) ...execute code... and posible fail...

after Vs restard windows form .... no display correctly and fail ..... ( see picture ) ( certain situations)

.( excuse me .. my english is bad.. )
Details
Sign in to post a comment.
Posted by Stuart Wood on 3/12/2012 at 8:54 AM
OK - may or may not have been this problem. Found the resolution at : http://stackoverflow.com/questions/3840108/custom-control-cause-visual-studio-2008-to-crash
Posted by Stuart Wood on 3/12/2012 at 8:38 AM
There's not a lot of info about the fix or workarounds for this - I just hit the problem described in VS2005. Is there a workaround that I can employ, assuming that 2005 isn't going to get a hotfix?
Posted by Microsoft on 10/16/2008 at 12:23 AM
Thanks for your feedback on the .NET Framework!

We are able to reproduce the bug that you reported and consider rolling in a fix to this issue in next release.

Many customers have found it useful to discuss issues like this in the forums (http://forums.microsoft.com/msdn/default.aspx?siteid=1) where Microsoft and other members of the community can suggest workarounds.

Please keep the feedback comming.

Thanks,
UIFx Team
Posted by Jose A. Fernandez on 7/9/2008 at 10:46 PM
I try with nested UC and IDE Close
http://support.microsoft.com/kb/839202/

My code
--Form1
----ucBotonCerrar
--------ucBotonDemo

Into ucBotonDemo...
Private Sub ucBotonDemo_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        If Not Me.DesignMode Then
            Application.Exit()
        End If
    End Sub

IDE VS2008 Close

My configuration:
- Windows Vista Ultimate (spanish).
- Visual Studio 2008 Team Suite (en).
- Visual Studio 2008 SP1 (Beta 1)

The code
http://cid-f5a5b07c2286412f.skydrive.live.com/self.aspx/Geeks.ms/winPruebaUserControlsANIDADOS%7C_byJoseFernandez.zip
Posted by Jose A. Fernandez on 7/9/2008 at 9:51 PM
I downloaded the test projec too, but I dont have any error.
All code work!
(I have VS2008 SP1-beta1)

My configuration:
- Windows Vista Ultimate (en, x86 - with Spanish MUI installed).
- Visual Studio 2008 Team Suite (en).
- Visual Studio 2008 SP1 (Beta 1)
Posted by Microsoft on 7/7/2008 at 1:29 AM
Thanks for your feedback. We are escalating this bug to the product unit who works on that specific feature area. The team will review this issue and make a decision on whether they will fix it or not for the next release.

Thank you,
Visual Studio Product Team
Posted by Nazul on 7/6/2008 at 4:59 PM
I downloaded the test project (winPruebaUserControls.zip) to validate the problem.

My configuration:
* Windows Vista Ultimate (en, x86 - with Spanish MUI installed).
* Visual Studio 2008 Team Suite (en).

I opened Visual Studio and loaded the project. When displaying the form in design view, I clicked the buttons and Visual Studio suddenly closes. No Error Reporting was show, the IDE just disapears.

When the IDE is opened again there is nothing saying something failed.
Sign in to post a workaround.