EnvDTE.CodeFunction.Attributes doesn't return attributes for get/set property accessors in C# - by Carlos J. Quintero

Status : 

  Won't Fix<br /><br />
		Due to several factors the product team decided to focus its efforts on other items.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


0
0
Sign in
to vote
ID 477218 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 7/26/2009 5:57:38 AM
Access Restriction Public

Description

When you use the file code model (EnvDTE.CodeFunction.Attributes) from an add-in or macro to get the attributes of get/set property accessors in C#, nothing is returned.
Sign in to post a comment.
Posted by Microsoft on 7/30/2009 at 6:22 PM
MVP CarlosQ,

Thanks for the feedback! Again, this is an issue that we would like to address but given that our current focus is on stabilizing and improving the performance of VS2010, we won't be able to address this issue for this release. I'm going to go ahead and resolve this bug as "Won't Fix" but please know that we'll be reviewing these issues as we begin planning for our next release. Thanks again for hte great feedback, and keep it coming!

Thanks,
DJ Park
C# IDE, Program Manager
Posted by Microsoft on 7/26/2009 at 8:44 PM
Thanks for your feedback.

We were able to reproduce the issue you are seeing. We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.