DEP Error Suite Integration Toolkit Executable installing on XP SP3 after uninstalling Beta 2 - by Keith Dorken

Status : 

  Duplicate<br /><br />
		This item appears to be a duplicate of another existing Connect or internal item.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


7
1
Sign in
to vote
ID 532560 Comments
Status Closed Workarounds
Type Bug Repros 7
Opened 2/10/2010 8:21:37 AM
Access Restriction Public
Primary Feedback Item 532171

Description

The VS2010 Professional RC installation fails.
It gets to the Visual Studio Setup screen, and when the progress bar gets to 100% it dies. Under some timing circumstances (depending on the speed of the install media, perhaps) the Next> button is enabled and the error does not occur until I click on it. 
The error is a Data Execution Prevention error, with the message "To help protect your computer, Windows has closed this program. Name: Suite Integration Toolkit Executable"
On closing this message an error log is sent to Microsoft, and the Setup quits, but it leaves the installer in some hung state that prevents any other installation from starting until the system is rebooted.

I have attached the screen shot of the error and the result file from the Collect utility.

The system is Windows XP SP3; VS2005 and VS2008 are installed. VS2010 Beta 2 had been installed but is now uninstalled.
Sign in to post a comment.
Posted by Alfredo De Regil on 2/22/2010 at 7:51 AM
The solution outlined worked for me. I have the product installed now.
Thanks.
Posted by Keith Dorken on 2/12/2010 at 7:38 PM
This appears to be the source of the problem. For some reason Tetron has the handwriting recognition turned on. Disabling that allowed Studio 2010 to install properly.
Posted by Microsoft on 2/12/2010 at 3:24 PM
Hi Keith,

When you have XP Pro SP3, then we've found that customers having similar issues have been fixed by following the guidance on the following site. Can you try their suggestions and let us know if this fixes your issue?

http://social.msdn.microsoft.com/Forums/en-US/setupprerelease/thread/dbcdcd52-d162-4460-9920-33c9ab54b36f
Posted by Alfredo De Regil on 2/12/2010 at 11:04 AM
I tried to turn off my Data Execution Prevention settings for the Suite Integration Toolkit Executable because I got an error saying that DEP blocked that program.

But when I try the installation after a windows reboot I get the same message and I go to the Performance Options / Data Execution Prevention tab and I see that there is a new (second) Suite Integration Toolkit Executable and it is not selected, so it blocked it.

Please let us know of any update to this issue.
Posted by Microsoft on 2/10/2010 at 8:55 PM
Thank you for reporting the issue.
We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution.These specialized experts will follow-up with your issue.
Posted by Microsoft on 2/10/2010 at 7:03 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Posted by Keith Dorken on 2/10/2010 at 8:24 AM
The vslogs.cab file is attached generated by the 'collect.exe' program mentioned frequently in this forum.
The .bmp is a screen shot of the error.