avx 256 bit intrinsics bug when compile in 64 bit - by Stan Melax

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


1
0
Sign in
to vote
ID 596345 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 9/8/2010 10:03:45 PM
Access Restriction Public

Description

my 8x3 transpose doesn't compile correctly when using x64 on vs2010
The resulting assembly code is not ideal and, in a similar function in a larger project, I had an issue with data output generated that was different than the 32 bit version.

I work for Intel and am working with the AVX 256 bit instructions/intrinsics.

Feel free to contact stan.k.melax@intel.com

Sign in to post a comment.
Posted by Stan Melax on 9/23/2010 at 2:21 PM
It appears this x64 compiler output captures the register spill issue, but not the correctness issue. I have come to learn that the register spill issue is being adressed. the stripped down code in this snippet does may not have any bad output issues.
Posted by Microsoft on 9/9/2010 at 2:52 AM
Thank you for reporting the issue.
We are routing this issue to the appropriate group within the Visual Studio Product Team for triage and resolution.These specialized experts will follow-up with your issue.
Posted by Microsoft on 9/9/2010 at 2:37 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)