Home Dashboard Directory Help
Search

Copy/Paste Korean Characters with VS2010 Code Editor by Jaewoo Ahn


Status: 

Closed
 as Fixed Help for as Fixed


2
0
Sign in
to vote
Type: Bug
ID: 629616
Opened: 12/7/2010 6:18:04 PM
Access Restriction: Public
2
Workaround(s)
view
0
User(s) can reproduce this bug

Description

If I try to copy source code including Korean Character from VS2010 Code Editor, and paste it to other apps like Word, weird character is displayed.
It happens when you select "Keep Source Formatting" as paste option, while not if you select "Keep Text Only" option.

See the "Steps to reproduce" for the details.

Note I tested it VS2010 English on Windows 7 English, and VS2010 Korean on Windows 7 Korean too. I got a same result. Also it worked correctly in VS2008.
Details
Sign in to post a comment.
Posted by Microsoft on 1/6/2011 at 5:17 PM
H Jaewoo - Apologies for the delayed response. We're glad to hear you've already installed the SP1 Beta and found that the copy/paste bug with East Asian characters is indeed fixed. I'll go ahead and resolve this issue, but if you have any further questions or comments, please feel free to post here at any time and we'll be happy to help.

Thanks for using Visual Studio 2010 and sending your feedback!

Brittany Behrens
Program Manager, Visual Studio Editor team
http://blogs.msdn.com/b/visualstudio
Posted by Jaewoo Ahn on 12/9/2010 at 6:47 PM
I installed VS2010 SP1 beta, and confirmed it was fixed.
Thanks for your effort.
Posted by Jaewoo Ahn on 12/9/2010 at 4:44 PM
Hi, I found someone reported same issue before as #550877, and VS Platform PM answered it already fixed. However, the hotfix is not provided yet as PM said that was not planned.

Is this fix included in VS2010 SP1? If so, I'll try it after installing VS2010 SP1 beta. If not, can you provide hotfix?
Posted by Microsoft on 12/7/2010 at 6:23 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Sign in to post a workaround.
Posted by Jaewoo Ahn on 12/9/2010 at 6:49 PM
Sorry, I mean VS2010 SP1 Beta is available.
Posted by Jaewoo Ahn on 12/9/2010 at 6:48 PM
This issue is fixed at VS2010 SP1 - Currently you can install VS2010 SP1.