Visual Studio stops responding to Keyboard Input - by gencha

Status : 

  Not Reproducible<br /><br />
		The product team could not reproduce this item with the description and steps provided.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 641783 Comments
Status Closed Workarounds
Type Bug Repros 21
Opened 2/7/2011 12:26:59 PM
Access Restriction Public


Occasionally Visual Studio 2010 will stop responding to most keyboard input. I've had this happen to me several times already on different machines while working on the same solution. It's only C# code. I have both ReSharper and the Visual Studio Productivity Tools installed. Some input, however, is still processed. Here are a few examples:

NOT Working:
Writing any letter, number or symbol in the code editor.
Navigating through the source code using any navigation key (Arrow Up, Page Down, etc).
Navigating the Solution Explorer using navigation keys.
Changing properties in the Properties panel.
Typing into the search textbox in the "Standard" toolbar.
All common hotkeys I tried (F5, F7 for Start Debugging, Build Solution)
Neither copying (Ctrl+C) nor pasting (Ctrl+V)

ReSharper Alt+Enter hotkey
ReSharper Ctrl+Alt+Shift+Up and Ctrl+Alt+Shift+Down
Alt+F to open the File menu (all menus can be navigated like that, however, arrow keys do not work)
Entering characters through Alt+NumPad combinations.
The Forward/Backward buttons on my Natural Ergonomic Keyboard 4000

The only way (I know of) to resolve this, is to restart Visual Studio.
Sign in to post a comment.
Posted by MarKayS on 9/29/2015 at 10:00 AM
Just happened to me now in Microsoft Visual Studio 2013. Happened after closing debug console. Nothing except restarting studio worked.
Posted by Richard Morrison on 9/15/2015 at 8:02 AM
I've had this happen in VS 2010, 2012 and just now in 2013. It usually happens to me when Visual Studio transitions out of the debugging. In my case, the focus is not in a window behind another editor. I can clearly see and move the insertion point at will (using the mouse). I can also switch from one code editor to another and focus that editor.

The windows however, do not respond to keyboard input, regardless of the location of the insertion point.
Posted by Marcel.van.Bree on 9/3/2015 at 2:24 AM
I do have it also in VS2013 and VS2015 (I'm using VB.Net). Damned frustrating, but after a while I saw that that the keystroke did appear on the window underneath the window I was supposing to type in...
I mean, I was changing the properties but my back-space wasn't working (all other keys where fine) and, after hitting it 20 times or so I saw the backspace was deleting the text in my code-window (underneath the design-window) So it seems the focus for my backspace only was wrong ????
I don't have resharper.
Anybody an idea ?
Posted by stkinh on 6/29/2015 at 3:44 AM
I have this in VS2013 professional, and there seems to be one prerequisite for thisto happen (not extensively tested but I got this impression several times now):
This only appears to happen when I leave VS2013 open when I hibernate the PC and wake it upnext day, possibly several days in a row.
Then sometimes the keyboard stops working in any editor window, closing VS may still leave the devenv.exe in taaskmgr, so I kick it, restart VS and it works again.
Posted by iXquisite on 3/19/2014 at 4:45 PM
Just had this happening to me in VS 2013 Ultimate - before I was able to recover with one of the workarounds, but this time nothing worked.
I have installed ReSharper though as well and I am wondering if it's between the two.
Posted by bkins on 10/22/2013 at 10:46 AM
Oh I forgot to mention, none of the workarounds have worked for me.
Posted by bkins on 10/22/2013 at 10:44 AM
I get the same thing using VS2012. Restarting VS works, but as millerstu said, it is a pain. Other apps work fine. the only keys that work are the Home and End keys. They toggle back and forth from my first tab to the last tab. Still trying to figure out at what point/action causes it to occur. So far it is sporadic. .... {I am starting to miss working in SharpDevelop...sigh....}
Posted by millerstu on 3/6/2013 at 12:03 PM
None of the work-arounds work for me. I've experienced this issue for at least a year (and it's extremely sporadic) in 2010 and 2012. Yes, I do have the power tools installed at the moment but prior to that I would still occasionally get a non-responsive keyboard. But it's only non-responsive in Visual Studio. Going to any other app, the keyboard works fine.

The only way is to shut down VS 2012 and restart. Unfortunately, our solution has a lot of code so shutting down is a real pain in the @$$.
Posted by Brijesh89 on 3/3/2013 at 9:34 PM
I have experienced the problem, and I just closed all opened files and restart the VS2010. It worked for me.
Posted by Quealdnal on 2/21/2013 at 6:59 AM
I also experience this issue randomly, which started suddenly and happens quite often. Restarting Visual Studio sometimes fixes the problem, but sometimes it doesn't. Luckily, I tried a workaround which seems to work (see my post in the workarounds tab).

I use Visual C++ and do not have ReSharper nor the Productivity Power Tools installed. The problem started happening at least 7 months after all the products (listed below) had been installed, so it doesn't seem to be something I did recently that broke it. Here is the complete list of installed products (menu: Help > About Microsoft Visual Studio)

Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Microsoft .NET Framework
Version 4.0.30319 SP1Rel

Installed Version: Ultimate

Microsoft Visual C# 2010 01019-315-4422995-70853
Microsoft Visual C# 2010

Microsoft Visual C++ 2010 01019-315-4422995-70853
Microsoft Visual C++ 2010

Microsoft Visual Studio 2010 Architecture and Modeling Tools 01019-315-4422995-70853
Microsoft Visual Studio 2010 Architecture and Modeling Tools
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Microsoft Visual Studio 2010 Code Analysis Spell Checker 01019-315-4422995-70853
Microsoft Visual Studio 2010 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Microsoft Visual Studio 2010 Team Explorer 01019-315-4422995-70853
Microsoft Visual Studio 2010 Team Explorer

Crystal Reports Templates for Microsoft Visual Studio 2010
Crystal Reports Templates for Microsoft Visual Studio 2010

Hotfix for Microsoft Visual Studio 2010 Ultimate - ENU (KB2546748) KB2546748
This hotfix is for Microsoft Visual Studio 2010 Ultimate - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit

Microsoft Visual Studio 2010 Ultimate - ENU Service Pack 1 (KB983509) KB983509
This service pack is for Microsoft Visual Studio 2010 Ultimate - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit

VisualSVN 2.5.5
Integration with Subversion version control. For more information about VisualSVN, see the VisualSVN website at
Copyright © 2005-2012 VisualSVN Ltd. All rights reserved.

Qt Add-in 1.1.11
This is Visual Studio Add-in component for Qt. For more information about Qt, see
Copyright (c) 2012 Digia Plc
Copyright (c) 2008-2012 Nokia Corporation and/or its subsidiary(-ies)
Posted by Icaro314 on 12/20/2012 at 2:28 AM
I had the same annoying problem and I solved it simply deactivating Microsoft's Productivity Power Tools.
I'm still using Reshaper with no problem of any sort for the moment
Posted by JulianClementson on 8/14/2012 at 2:39 AM
I also experience this from time to time. I can type letters and numbers, but other keys (e.g. arrow keys, return) do not work.

I have ReSharper 6.1 installed, and I suspect it is related to the way ReSharper registers its keyboard shortcuts with VS. But whether the bug is in ReSharper or VS itself is impossible to tell.
Posted by prearrangedchaos on 7/11/2012 at 12:55 AM
Happens to me every now and then... Twice today. I have Resharper 5.1 installed. Maybe that is causing the issue.
Posted by wimk on 6/29/2012 at 1:07 PM
Although this is marked as closed, it is definitely a problem for me. Since I upgraded VS 2010 with the CSS 3.0 addon this problem appears.
Because i want to develop webpage using xHTML and CSS 3.0 i needeed this upgrade unknowing that this problem comes with the upgrade.!!
Posted by karl_austin on 6/11/2012 at 10:04 AM
Although this is marked as closed, it is definitely a problem for me. The only add-in I have installed is Ankh. It happens on multiple machines, too. It happens several times an hour. I've actually resorted to notepad at times because it is such a pain. It appears to be quite random. I have tried to come up with steps to replicate, but so far, no go. It happens almost exclusively on aspx pages. When it does, I close the aspx page I'm editing, click on another one, then reopen. That usually, but not always, straightens it out. For 30 minutes.
Posted by Purpledragon on 11/24/2011 at 6:07 AM
Just to say this has happened three times today - no idea why, obviously very annoying - I am on VS 2010 SP1 - it won't accept any keyboard input - I can't use F10 or type anything, all I can to is click with the mouse. The only solution is to close VS and open it again. I haven't had this happen before.

Posted by jd31068 on 8/19/2011 at 5:20 AM
I experience this as well; I will be coding in the IDE when suddenly VS stops accepting keyboard input. I close VS and reopen and its ok. This is a sporadic experience in that I can go for days without it happening or it can happen 3 days in a row.

Very annoying but thankfully not a danger to the project being worked on at the time.

I am working with and client side work in the aspx or js files (jQuery, AJAX, JSON)
Posted by Eddy Collins on 8/2/2011 at 10:31 AM
I'm new to ASP.NET and using VS 2010, but this has happened twice to me. Things I noted were I was in an ASP.NET MVC 3 .cshtml view both times. The down arrow key indicated focus on the "Client Objects & Events" dropdown box just above the code window. Mouse clicks worked but still did not allow keyboard entry after clicking. Attempts to reproduce were unsuccessful, but it may have happened after the intellisense popup was cancelled out of. This last time I did have Productivity Tools installed, but not the previous time.

The stuck focus on the "Client Objects & Events" dropdown seems to be the key. Perhaps because there are no actual objects in a .cshtml view???
Posted by EvilDr on 5/26/2011 at 5:36 AM
This issue (or very similar) is also reported at the following links:

Could they be combined given them a significant Vote boost? I *think* the problem is related to Productivity Power Tools...
Posted by JonW_2012 on 4/20/2011 at 3:24 PM
More info - this just started happening to me again, so I was careful to see what was going on. As soon as I press the control key, Visual Studio loses Focus. I don't know where the focus is going to, but I can't do any ctrl+key combinations because once I press control, the focus is gone. I can tell it's losing focus because the title bar of the Visual Studio window changes color so that it appears as an inactive application.

When I went back to Visual Studio after beginning this comment, it appears to be working normally again. This problem is very sporadic.
Posted by JonW_2012 on 4/20/2011 at 2:50 PM
Just wanted to add that my coworker and I also experienced this problem recently in VS 2010. We eventually closed Visual Studio and restarted it and the problem was fine.

We verified that keystrokes worked fine in other applications (Notepad, etc), the problem was only in Visual Studio.

At the time we were completely perplexed, but today I have a suspicion about the cause. It may be that the focus was not where you thought it was and keystrokes didn't seem to be working. There are so many shortcut keys in Visual Studio, that it's easy to inadvertently type a command and not realize you did it.

To give a specific example, I noticed that the "find" pop-up was docked as a panel in VS, but it was so small that I could not see the field where you type what you are searching for. So, if I pressed ctrl+f, my cursor would go to this field in the docked panel, meanwhile I am looking at my screen wondering why I don't have the pop-up. Plus, now as I am typing nothing is happening.

The O.P. may have had a similar situation where when he was copying and pasting he accidentally triggered a different shortcut that put his cursor somewhere other than the code window, and did it in such a subtle or invisible way that it simply seems that the program stopped responding to keystrokes.
Posted by Fast Armadillo on 3/28/2011 at 9:33 AM
This is a legitimate problem. I'm having it now repeatedly on several projects. Specifically the html editing stops working in code view.

I can't seem to find any logic to it - but it does seem to happen more often when I'm using copy/paste functionality to move sections of code around.

I'd love a fix for this.
Posted by gencha on 3/6/2011 at 12:20 PM
Sorry, but I had trouble with my mail server and only just got the notifications about this ticket.

I hadn't noticed any patterns in my work that would have triggered the issue. Additionally, since I reported the issue, the problem hasn't happened again (even though I was temporarily working on a non-VS project). I'm back to my regular project/work now and "hope" to be able to reproduce the issue again.
Sadly, I don't think I will be able to work without my VS extensions. Especially since I can't reproduce the issue reliably.

Would there be anything I could do when the issue has already happened that would help with the analysis? Like creating a dump of the process or attaching a debugger to VS itself?
Posted by Microsoft on 3/4/2011 at 2:21 PM
Hi gencha - Because we haven't heard from you in the last ten days or so and have not yet been able to reproduce this bug, I'm unfortunately resolving it as Not Repro. This is by no means final; if/when you have a chance to reply with more details, please feel free to post again here and/or reactivate this bug at any time and we'll take another look.

Thanks again for your feedback,
Posted by Microsoft on 2/22/2011 at 5:20 PM
Hi gencha,

Thank you for reporting this issue. Unfortunately bugs like this where keyboard input just stops working are very difficult to investigate without repro steps, and the involvement of the Productivity Power Tools and ReSharper only complicate the situation. We know this is inconvenient, but could you try working without the power tools and ReSharper for a few hours and let us know whether the problem still occurs during that time? Any details you notice about when this bug happens - always the same file type, project, actions you do before it happens, etc. - would also be extremely helpful.

Thanks for using VS 2010 and sending your feedback! We hope to hear from you soon.

Brittany Behrens
Program Manager, Visual Studio Editor team
Posted by Microsoft on 2/7/2011 at 3:00 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(