GDI+ and WIC: Opening an 8bpp grayscale JPEG results in quality loss - by brischt

Status : 

  Won't Fix<br /><br />
		Due to several factors the product team decided to focus its efforts on other items.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


2
1
Sign in
to vote
ID 649605 Comments
Status Closed Workarounds
Type Bug Repros 3
Opened 3/5/2011 6:07:11 AM
Access Restriction Public

Description

When opening an 8bpp grayscale JPEG on Windows 7 using GDI+ and WIC, quality of the image degrades (is interpreted as 4bpp).
Sign in to post a comment.
Posted by Microsoft on 11/9/2011 at 1:55 PM
Thank you for reporting this issue - we have followed up with the GDI+ team on your behalf.

Customer feedback is a critical part of a successful, impactful software product. Unfortunately another part is the reality of schedules and the need to prioritize investments according to the objectives of the product. We have evaluated the issue that you have reported and at this point in the product's lifecycle, it does not meet the criteria to be addressed. This evaluation is carefully done and considers many aspects including the cost of the fix, implications of the change, and the number of reported instances of the issue.

Many customers have found it useful to discuss issues like this in the forums (http://www.microsoft.com/communities/forums/default.mspx) where Microsoft and other members of the community can recommend ways of achieving the behavior you are interested in.

Thank you,
The Windows Forms Product Team
Posted by rwong_002 on 7/14/2011 at 6:42 PM
This bug is widely reportedand affects both GDI+ and WIC on Windows 7. Here I only include a few but it is not difficult to find many other reports on the Internet.

http://social.msdn.microsoft.com/Forums/en-US/windowswic/thread/196aae97-42da-4942-b978-105c7efde0f1
(This one includes both a reproduction project and a workaround code for WIC)

FYI the workaround code is in http://cid-7f230655afbc923b.office.live.com/self.aspx/Windows%20Imaging%20Component%20Bugs/Windows7%5E_8bppBitmap%5E_Fixed.zip

http://social.msdn.microsoft.com/Forums/en-US/windowsgeneraldevelopmentissues/thread/af19a398-8012-488a-96e7-5c48bd6b1573
Posted by Microsoft on 3/7/2011 at 12:56 AM
Thank you for submitting feedback on Visual Studio 2010 and .NET Framework. Your issue has been routed to the appropriate VS development team for review. We will contact you if we require any additional information.
Posted by Microsoft on 3/5/2011 at 6:14 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)