Visual Studio Service Pack 1 crash build result view - by EricDelahaye

Status : 

  Duplicate<br /><br />
		This item appears to be a duplicate of another existing Connect or internal item.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 651846 Comments
Status Closed Workarounds
Type Bug Repros 12
Opened 3/16/2011 1:08:33 PM
Access Restriction Public


The error message in build result view is:
"TF50316: The following name is not valid <Global>. Verify  that the name does not exceed the maximum character limit, only contains valid characters, and is not a reserved name"

I have been using TFS 2008 SP1 and Visual Studio 2010 without problems until I installed Service Pack 1 on Monday and since then it hangs when I see that the result of a build. This always happens and we can play on other machines. Another thing started to happen is visual studio crashes so doing chekins Randomized

In spanish
Tengo TFS 2008 SP1 y estaba utilizando Visual Studio 2010 sin problemas hasta que instalé el Service Pack 1 el lunes pasado y desde entonces se cuelga cuando quiero ver que resultado de un build. Esto ocurre siempre y lo podemos reproducir en otras maquinas. Otra cosa que empezo a pasar es cuelgues de visual studio de forma aleatorea realizando chekins.
Sign in to post a comment.
Posted by Adam [MSFT] on 3/22/2011 at 5:54 AM
A hotfix for this has been released and is available at
Posted by Adam [MSFT] on 3/21/2011 at 8:14 AM
We have reproduced the issue and will have a hotfix available very soon. We're actually tracking this using a different connect bug,, so I'm resolving this as a duplicate.
Posted by Helen [MSFT] on 3/17/2011 at 9:48 PM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.

Posted by rockyMtnRajah on 3/17/2011 at 2:17 PM
I am having the same problem and here is more information:

VS2010 - Ultimate
Team Build 2008

In the build explorer when a build completes and when I double click the build I get the following error:
TF50316: The following name is not valid: <Global>. Verify that the name does not exceed the maximum character limit, only contains valid characters and is not a reserved name.
Parameter name: projectName.

This used to work prior to us installing VS2010 Service pack 1

Additional information:
In the application logs this is the information that gets published:
Error Event:
The description for Event ID 0 from source VSTTExecution cannot be found......

The following information was included with the event:

(devenv.exe, PID 5436, Thread 1) StringToVariantHelper.WriteSafeArrayToVariant: Failed to clear the variant. Exception message: Bad variable type. (Exception from HRESULT: 0x80020008 (DISP_E_BADVARTYPE))

the message resource is present but the message is not found in the string/message table
Information Event:

Fault bucket 1777309557, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: devenv.exe
P2: 10.0.40219.1
P3: 4d5f2a73
P4: Microsoft.TeamFoundation.Build.Controls
P6: 4d5f3df2
P7: 238
P8: 39
P9: System.NullReferenceException

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: ed966f4c-50da-11e0-807a-002264a49915
Report Status: 0
Posted by Matthew M. Merrill on 3/17/2011 at 1:58 PM
Received the exact error message that Eric B. Delahaye reported, which is shown for one second before Visual Studio shut down.
Uploaded the dump file that I captured at

Posted by Matthew M. Merrill on 3/17/2011 at 11:03 AM
I encounter the same problem when I try to view the build details in Team Explorer in Visual Studio 2010 after applying service pack 1. However, for me, I can view the build list, but when I double-click the build to view the results and details, Visual Studio 2010 crashes and shuts down with no error message being displayed.
Posted by EricDelahaye on 3/17/2011 at 6:39 AM
The dump file was uploaded.
Posted by pbloechl on 3/17/2011 at 12:46 AM
Same problem here on our TFS2008 hosted project; If I double click a build to see the details I get this errormessage...
But when accessing via the TSWA-frontend I'm able to see the details... as also with the (local) Visual Studio 2008 Team Explorer.

Accessing builds on our TFS2010 hosted instance with VS2010SP1 are fine; no problem in that configuration
Posted by Helen [MSFT] on 3/16/2011 at 7:36 PM
Thank you for submitting feedback on Visual Studio 2010 and .NET Framework. In order to efficiently investigate and reproduce this issue, we are requesting additional information outlined below.
It may help if you provide us with a dump file and call stack.

You can get detailed steps about how to get the dump file and call stack at

Or you can download a Visual Studio 2010 Diagnostic Tool from You can get detailed description about how to use it to collect dump file.

Please zip the file and use "FeedbackID-651846" as prefix of the file name.

You can use the following workspace to upload the file:
Password is 9f]XUpR2Vq

Please submit this information to us within 4 business days. Thanks again for your efforts and we look forward to hearing from you.

Microsoft Visual Studio Connect Support Team

Posted by Bismarck84 on 3/16/2011 at 1:16 PM
The same problem happens to me, it looks like the tfs is hanging the VS 2010 instead of waiting for a timeout.
Posted by Microsoft on 3/16/2011 at 1:14 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(