MFC - OLE Automation - COleObjectFactory Registry Registation fails with blanks in Path - by M. Zuehlke

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 661289 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 4/14/2011 6:58:54 AM
Access Restriction Public


With VS2010 the OLE Registration with COleObjectFactory::RegisterAll() / COleObjectFactory::Register() slightly changed.

Within the function _AfxOleMakeSymbolTable the path of the module is now determined by AfxGetModuleFileName instead of AfxGetShortModuleFileName (VS2008). This means there can be blanks within the path, thus the value needs to be enquoted when written into the registry (for the ....\LocalServer32\ value) but this is not done.

This results in an error 'invalid win32 application' when calling COleDispatchDriver->CreateDispatch().

Please review this change carefully and remove the bug.
Sign in to post a comment.
Posted by Microsoft on 4/26/2011 at 3:22 PM

Thanks for the report. This issue has been fixed in MFC for the next major release of Visual Studio.

Pat Brenner
Visual C++ Libraries Development
Posted by Macy [MSFT] on 4/15/2011 at 1:07 AM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Microsoft on 4/14/2011 at 7:13 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(