Click-Once + .NET Framework 4 Platform Update 1 - by jonstelly

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


11
0
Sign in
to vote
ID 664933 Comments
Status Closed Workarounds
Type Bug Repros 3
Opened 4/26/2011 9:52:53 AM
Access Restriction Public

Description

If I build a WPF application targetting .NET 4 Platform Update 1, then publish a click-once package for it, the targetFramework version is set to 4.0.1 in the .application file.  Click-once complains that framework 4.0.1 is required, even though I have the Platform Update 1 installed on the target machine.  This also fails even on the developer machine where I built the application.

If I use MageUI I can edit the targetVersion to 4.0.0 and resign and everything works, but it doesn't seem like I should have to do that.
Sign in to post a comment.
Posted by Silvio Katzmann on 4/16/2012 at 12:34 AM
You are joking, right?
You close this bug and there is no fix of it.
There is just a workaround.
That's not acceptable from each point of view.
Please reopen this Bug!
Posted by Microsoft on 8/10/2011 at 10:52 AM
Thank you for your feedback. This is a bug that we are looking at fixing in one of our next releases.
Posted by Microsoft on 4/26/2011 at 7:47 PM
Thank you for submitting feedback on Visual Studio 2010 and .NET Framework. Your issue has been routed to the appropriate VS development team for review. We will contact you if we require any additional information.
Posted by Microsoft on 4/26/2011 at 10:13 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)