MS Interop Forms Toolkit - problems with globals and events - by thodem

Status : 

  Won't Fix<br /><br />
		Due to several factors the product team decided to focus its efforts on other items.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


1
0
Sign in
to vote
ID 729007 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 3/5/2012 11:54:17 PM
Access Restriction Public
Moderator Decision Sent to Engineering Team for consideration

Description

I'm using the MS Interop Forms Toolkit 2.1 in an own project which I have allready convertet into VS 2010 and .NET Framework 4.0. This 4.0 Framework ist required because of any other used components.
By the Interop Toolbox Globals I transmitted values that are necessary. But now with .NET Framework 4.0 no one of the added values I get in VS 2010 - all values are NULL.
In a forum I read, that this is an known problem since August 2011 - when can I get an solution for this?
Next problem is that no event raised in .NET will be raised in COM...

Regards
Th. Demmler 
Sign in to post a comment.
Posted by Microsoft on 4/22/2014 at 4:52 PM
Hi - the Interop Toolkit was designed for .NET Framework 2.0. I'm sorry to hear you're having this issue on .NET 4.0, that is a valid scenario just not one we set out to support.

The source code is provided with the Toolkit. Is there any chance that helps you to deal with Framework 4.0 paths and types?

thanks,
Paul

Feel free to email me directly at paulyuk@micr0s0ft.c0m (change 0's to o's)
Posted by thodem on 8/22/2012 at 2:12 AM
Hello!

Once again: When will I get a solution for my problem???????

Regards
Th. Demmler
Posted by thodem on 4/18/2012 at 11:14 PM
Hello!

When will I get a solution for this problem?

Regards
Th. Demmler
Posted by Microsoft on 3/22/2012 at 2:49 AM
Thanks for you update. We are rerouting this issue to the appropriate group within the Visual Studio Product Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by thodem on 3/15/2012 at 4:01 AM
Hi,

I have attached some projects in a zip-file. In path IOPFormsTest you can find an VB.NET solution with Framework 2.0 using MS Interop Forms Toolkit. In the same path you will find an VB6 project using the .NET Form. If you start the .NET project an than the VB6 project and run the last one you can see a button caption in the .NET form "hello world!". If you click on this you will get an event in VB6 with a messagebox...

The path IOPFormsTest_Framework40 contains the same projects but I changed the Framework from 2.0 to 4.0. If you try the same as described above you will see no button caption in the .NET form and no event will be fired in VB6...

So I hope you can reproduce the problem easy!

Regards
Th. Demmler
Posted by Microsoft on 3/14/2012 at 1:37 AM
Thank you for reporting this issue. Could you please attach some screenshots about this issue?
Posted by MS-Moderator01 on 3/6/2012 at 5:49 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)
Posted by MS-Moderator08 [Feedback Moderator] on 3/6/2012 at 1:08 AM
Thank you for reporting this issue. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.