Cannot run Visual Studio 2012 remote debugger on Windows Server 2008 (non-R2) - by JustinPealing

Status : 

  Duplicate<br /><br />
		This item appears to be a duplicate of another existing Connect or internal item.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 763521 Comments
Status Closed Workarounds
Type Bug Repros 12
Opened 9/19/2012 6:35:37 AM
Access Restriction Public


I'm trying to run the Visual Studio 2012 remote debugger on a Windows Server 2008 x86 (not R2) virtual machine, but I can't get past the "Remote Debugging Configuration" screen as the Windows Web Services API fails to install.

As this update does not appear to be available as a public download this means that I am unable to remotely debug a Windows Server 2008 (non-R2) machine using Visual Studio 2012.

See also

Sign in to post a comment.
Posted by Edgars Batnya on 8/1/2013 at 2:48 AM
Posted by aaron.carlson on 4/15/2013 at 9:31 AM
This defect was closed as a duplicate. Can someone post the link the the live version of this defect?
Posted by markwilliamsps on 12/18/2012 at 9:53 AM
Looks like Server 2008 is not supported by Visual Studio 2012.
Posted by markwilliamsps on 12/18/2012 at 6:56 AM
I am having the same issue. I took the same steps as JustinPealing did below. I am also running 2008 with all relevant updates installed.
Posted by Donatas on 9/25/2012 at 7:10 AM
Using fiddler I've noticed msvsmon.exe is going for a URL when I press "Configure remote debugging"

I guess this used to take to a setup file but now it's broken.
Posted by Steve Hurcombe on 9/24/2012 at 5:33 AM
Same problem here too.
Posted by JustinPealing on 9/24/2012 at 5:04 AM
This is on the x86 edition of Windows Server 2008.The steps I'm taking to install the remote debugger are:

1. Go to and download the "Remote Tools for Visual Studio 2012"
2. Run the setup without changing any options

This part of the installation works successfully and from this point I'm just following the steps shown in the "Steps to reproduce section of this ticket" which is where the problem lies.

For what its worth I've tried several different methods of setting up the remote debugger, all of them result in the same error.
Posted by Farina on 9/21/2012 at 3:35 PM
I'm having the exact same problem. The 2010 remote debugger no longer works for VS 2012, so I'm out of luck unless you can come up with a solution.
Posted by Microsoft on 9/21/2012 at 11:34 AM
Can you please describe the steps you took to install the remote debugger onto your Windows Server 2008 machine?

Are you running the x86 or x64 version of Windows Server 2008?

Visual Studio Debugger Team
Posted by Microsoft on 9/20/2012 at 1:26 AM
Thanks for your feedback.

We are rerouting this issue to the appropriate group within the Microsoft Visual Studio Connect Support Team for triage and resolution. These specialized experts will follow-up with your issue.
Posted by Helen [MSFT] on 9/19/2012 at 6:51 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(