keyboard assignment for Ctrl-Shift-ArrowUp/Down does not work - by chksr

Status : 

 


0
1
Sign in
to vote
ID 773542 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 12/5/2012 6:12:31 AM
Access Restriction Public

Description

Using VS2012, I cannot assign keyboard shortcuts to

Ctrl-Shift->ArrowDown
Ctrl-Shift->ArrowUp
Sign in to post a comment.
Posted by Microsoft on 1/30/2013 at 6:02 PM
Thank you for reporting this issue and using Visual Studio. After following your instructions, we are unable to reproduce this issue internally, so we have no choice but to resolve this bug as Not Repro. If you surface more details about the problem, we would love to turn it into an actionable bug that we can investigate further.

Thank you,
Ala Shiban | Program Manager | Visual Studio Professional - Language Experience Team
Posted by chksr on 12/17/2012 at 10:47 PM
At the time I first tried it, I had none. This was one of my main productivity shortcuts (does that mean I have too many errors as it's important for me to be able to skip through them <grin>?)

Now I have Code Alignment, Indent Guide, Productivity Power Tools, VS Commands.

Well if it's only me, you might forget it (although I'd like it to work, as I am still not used to my alternative solution Ctrl-Shift-'+' and '-'). But I guess the time it would be fixed, I'm used to these new keys ;)
Posted by Microsoft on 12/17/2012 at 8:31 AM
Thanks for your feedback. Could you please let us know which extensions you have installed?

Thanks,
Ala Shiban
Program Manager | Visual Studio Professional - Editor team
Posted by chksr on 12/12/2012 at 11:02 PM
Just try to assign an action (here I used Edit.GoToNextLocation and Edit.GoToPrevLocation) to the mentioned key combination Ctrl-Shift-ArrowDown or Ctrl-Shift-ArrowDown using Tools > Customize > Keyboard.

You can assign the action, but then nothing happens when I press that combination later on to jump from compiler message to the next or previous one.

Using Ctrl-Shift-'+' and Ctrl-Shift-'-' it works, so I have a workaround, I just need to get adjusted to the new combinations. Still I wanted to tell you there's a problem somewhere, and I'd lie the Arrow keys better ;)

I cannot tell whether it worked in VS2010, but in 2008 this was working.
Posted by Microsoft on 12/12/2012 at 12:52 PM
Thanks for your feedback. Using Visual Studio 2012 RTM, we haven't been able to reproduce the problem internally. Can you please describe in more detail the scenario you're trying to cover?

The more details you can provide, the higher the chances we have of reproducing and tracking the issue.

Thank you,
Ala Shiban | Program Manager | Visual Studio Professional - Editor team
Posted by Microsoft on 12/6/2012 at 3:05 AM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by Microsoft on 12/5/2012 at 6:52 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)