RTL Menu on windows 8 - sub menus goes the wrong direction - by Daniel-IL

Status : 

  External<br /><br />
		This item may be valid but belongs to an external system out of the direct control of this product team.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 777344 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 1/23/2013 10:15:49 PM
Access Restriction Public


This it NOT a visual studio bug, but I think it is better posted here.

WPF - if you use a menu with flow right to left, the submenus will be opened to the wrong direction (aligned to the left side and not to the rigth side)

ON WINDOWS 8 machines. same codes works OK on Win 7 and XP.
Sign in to post a comment.
Posted by Daniel-IL on 2/2/2013 at 3:06 AM
This is a problem with the way win8 deals with xaml.
I'm not sure which team needs to deal with it, but I think it should be address by someone.
This is not critical for me, as most of my clients doesn't like the win 8, but this is a shame that the same exe behaves differently on 2 Microsoft's OS.
Please refer this issue to the right person in MS.....
Posted by Macy [MSFT] on 1/31/2013 at 2:34 AM
Thanks for your response. Based on your description this is not a visual studio issue, I will close this issue. This issue appears to be on a released Windows Product. If this issue is severe, causing critical business situations or blocking your product development or deployment, please go to http://support.microsoft.com or call 1-800-MICROSOFT for assistance. For Microsoft premier customers, please contact your administrator, your Technical Account Manager, or your Microsoft premier account representative.
Posted by Daniel-IL on 1/30/2013 at 11:57 AM
Attached the project and the files.
did you see the pictures ?
This is not a visual studio issue, it's a win 8 issue....
Posted by Macy [MSFT] on 1/29/2013 at 2:12 AM
Thanks for your response. But we are unable to reproduce this issue. Could you please give us a demo project to demonstrate this issue?

Additionally, please export and reset environment settings file by clicking Tools-> Import and Export Settings, after that, please zip the file and send it to us so that we can conduct further.

Microsoft Visual Studio Connect Support Team
Posted by Daniel-IL on 1/25/2013 at 12:05 PM
I've attached 2 jpg files from win 8 (you can see the xaml there and the same exe on win 7 where it works ok.
If you need anything else let me know
Posted by Macy [MSFT] on 1/24/2013 at 1:53 AM
Thank you for submitting feedback on Visual Studio and .NET Framework. In order to fix the issue, we must first reproduce the issue in our labs. We are unable to reproduce the issue with the steps you provided.

Could you please give us a demo project or some screenshots to demonstrate this issue?

Please submit this information to us within 4 business days. We look forward to hearing from you with this information.

Microsoft Visual Studio Connect Support Team
Posted by Macy [MSFT] on 1/23/2013 at 10:49 PM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)