SP2010 VisualWebPart template in VS2012 - by Lenard Schouten

Status : 

  Fixed<br /><br />
		This item has been fixed in the current or upcoming version of this product.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


1
0
Sign in
to vote
ID 778462 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 2/4/2013 7:07:13 AM
Access Restriction Public

Description

In the VisualWebPart template of VS2010 it's possible to load an adittional user control.
In VS2012 it isn't. After adden a User Control you get compiler errors.
Sign in to post a comment.
Posted by Microsoft on 4/29/2014 at 12:29 PM
Thank you for reporting this issue. This issue has been fixed in Visual Studio 2013. You can install a trial version of Visual Studio 2013 with the fix from: http://go.microsoft.com/?linkid=9832436
Posted by Microsoft on 2/18/2013 at 12:53 PM
Hi Lenard,

This issue is caused because the Visual Web Part template in VS2012 is altered to better work with sandboxed solutions. The sandboxed solutions don't support user controls.

Thanks,
Xiaoying Guo
Program Manager, Visual Studio SharePoint Developer Tools Team
Posted by Microsoft on 2/4/2013 at 10:44 PM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by Microsoft on 2/4/2013 at 7:50 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)