Help Explorer cannot display some topics - by sba

Status : 

  External<br /><br />
		This item may be valid but belongs to an external system out of the direct control of this product team.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 785663 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 4/26/2013 3:29:09 AM
Access Restriction Public


When I search for WM_INPUT in the Help Explorer, I get a number of results.

Clicking on the first one ("WM_INPUT message (Windows)") yields a "Cannot find requested topic on your computer" error.

Searching for WM_INPUT with F1 works, and also in the standalone Help Viewer 2.0.

(FWIW: the help content is stored on a network share, populated by IT people)
Sign in to post a comment.
Posted by Microsoft on 5/8/2013 at 8:09 AM
Greetings sba

Thank you for submitting a Connect bug for the Help system. The issue you are seeing is with the Integrated Help extension that was downloaded from the Visual Studio Gallery ( The code is managed by the author, Jason Josephy. The below is posted on the Gallery page.

Each contribution is licensed to you under a License Agreement by its owner, not Microsoft. Microsoft does not guarantee the contribution or purport to grant rights to it.

The local Help viewer will source content from online if that topic is not installed locally. If that happens, there will be a disclaimer across the top if the topic notifying you that the topic is being sourced from online. If that is the case, then you should install the book containing the topic to the local store.

Since you hare having issues with the Gallery extension, you should post the problem you are seeing on the extension web page, for the author to address.

Thank you,

Malcolm Dickson
IDE Experience Program Manager
Posted by Microsoft on 4/30/2013 at 3:41 AM
Hi sba, thanks for your response. Your issue has been routed to the appropriate VS development team for investigation.
Posted by sba on 4/29/2013 at 12:52 AM
Here are the full details:

- in Help Viewer 2.0 I type WM_INPUT in the Search tab. The *first* result (of way more than 3!) is "WM_INPUT message (Windows) Sent to the window that is getting raw input. A window receives this message..." If I click on this in the list of results I do get the document opened (ms-xhelp:///?method=page&id=VS%7CWINUI%7C~%5CWINUI%5CWINDOWSUSERINTERFACE%5CUSERINPUT%5CRAWINPUT%5CRAWINPUTREFERENCE%5CRAWINPUTMESSAGES%5CWM_INPUT.HTM&locale=en-US&vendor=Microsoft&format=html&topicversion=85&topiclocale=EN-US).
- in VS2012.1 if I do Help / Help Explorer then enter WM_INPUT in the Search tab, I get the same first result as in Help Viewer 2.0, but if I click on it I get an error page in VS ("Cannot find requested topic on your computer")
- If I hit F1 on WM_INPUT (in a .cpp file FWIW) I do get ms-xhelp:///?method=page&id=VS|WINUI|~\WINUI\WINDOWSUSERINTERFACE\USERINPUT\RAWINPUT\RAWINPUTREFERENCE\RAWINPUTMESSAGES\WM_INPUT.HTM&vendor=Microsoft&topicLocale=EN-US&topicVersion=85
Posted by Microsoft on 4/28/2013 at 8:15 PM
Hi sba, thank you for submitting feedback on Visual Studio and .NET Framework. At first, i want to describe my case to repro this issue. In Help Viewer 2, i typied WM_INPUT in search tab, then i saw 3 results. The title of the first issue is FilterInputMessage, i could open this issue successfully. Were my steps right? I couldn't find results of WM_INPUT in contents tab and index tab. I want to confirm WM_INPUT message (Windows) is FilterInputMessage? Thanks for your time.
Posted by Macy [MSFT] on 4/26/2013 at 3:52 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(