= default not working for move constructor in Visual C++ 2013 RC - by Dev Alex B

Status : 

  Duplicate<br /><br />
		This item appears to be a duplicate of another existing Connect or internal item.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.


14
0
Sign in
to vote
ID 800114 Comments
Status Closed Workarounds
Type Bug Repros 6
Opened 9/10/2013 4:58:41 AM
Access Restriction Public

Description

Following won't compile:

struct A
{
	A(A&&) = default;
};
Sign in to post a comment.
Posted by jasonsa on 5/13/2014 at 6:14 PM
btw, I noticed this:
http://msdn.microsoft.com/en-us/library/hh409293.aspx

says
* For defaulted functions, using =default to request memberwise move constructors and move assignment operators is not supported.
Posted by Henk-Jan Lebbink on 1/23/2014 at 5:22 AM
This is a show stopper, any workarounds? And where is the duplicate??
Posted by Vadim Zeitlin on 1/17/2014 at 7:14 AM
This is closed as a duplicate but where is the other issue? I'd like to monitor it but I can't find it.
Posted by Microsoft on 9/11/2013 at 3:14 AM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by Microsoft on 9/10/2013 at 5:50 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(http://support.microsoft.com)